Re: [PATCH] PM: Hide CONFIG_PM from users

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

On Monday, February 07, 2011, Mark Brown wrote:
> On Mon, Feb 07, 2011 at 08:14:03PM +0100, Rafael J. Wysocki wrote:
> > On Monday, February 07, 2011, Mark Brown wrote:
> > >  config PM_DEBUG
> > >  	bool "Power Management Debug Support"
> > I think it would be better to simply rename CONFIG_PM_OPS into CONFIG_PM.
> That still leaves the IA64 emulator to worry about

Why exactly?

> but I'm not fundamentally opposed to that, it achieves a similar effect.  The
> main thing I'm looking for here is to cut down on the configuration options
> we have to maintain.

But I must say you chose a particularly bad time for that from my point of view.

> > However, there's a number of things that I'm afraid wouldn't build correctly
> > if none of CONFIG_PM_SLEEP and CONFIG_PM_RUNTIME were set in that case.
> Actually CONFIG_PM_OPS probably also wants to be on independantly of
> those two sometimes for .poweroff() which I'd expect to run even if we
> can't suspend.

If you worry about that, then add CONFIG_PM_POWEROFF and make CONFIG_PM(_OPS)
depend on it, but I don't think it really is worth it, because people
generally don't make the poweroff code depend on CONFIG_PM.

To unsubscribe from this list: send the line "unsubscribe linux-embedded" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Gstreamer Embedded]     [Linux MMC Devel]     [U-Boot V2]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Linux Kernel]     [Linux OMAP]     [Linux SCSI]     [XFree86]

Add to Google Powered by Linux