Google
  Web www.spinics.net

Problem in accessing EN50221 card registers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Good hello,
   I have a PCMCIA CAM card on EN50221 standard.
   The card is interfaced to BCM7324 on EBI lines.
    Board detects the card,and it has to get initialised through proper sequence .The sequence follows :set Reset bit and Poll for Ready bit in command Register
The offset of Command Register is 0x1
   the processor address pins and    CAM address pins  are interfaced as follows
  Processor                 CAM Card
   A3<------------------------>A2_CAM
   A2<-------------------------->A1_CAM
   A1<-------------------------->A0_CAM
   ........
  processor does not show A0 .I suppose this is for even address alignement.
CAM memory map for command Register is
A0_CAM=1
A1_CAM=0

   Hence to configure 0x1 offset(Command Register) i do
  CHIP_SELECT=0x1A000000
   *(ioremap(CHIP_SELECT+2,0x4) =value.

  I think CHIP_SELECT+2 should select A0_CAM=1 ;
  Am I right on this?

  But when i read the command register value i don,t get correct value.

  Can someone please tell me if i select the registers properly as
  written above ? Or please suggest me something else to be done .

Warm Regards,
 Vivian


  
 
                                                                                  
  

  
   
 
  
_______________________________________________
linux-dvb users mailing list
For V4L/DVB development, please use instead linux-media@xxxxxxxxxxxxxxx
linux-dvb@xxxxxxxxxxx
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

[Linux Media]     [Video 4 Linux]     [Video Technology]     [Asterisk]     [Photo]     [Samba]     [Xorg]     [Xfree86]     [Devices]     [DVB Maintainer]     [Linux USB]