Google
  Web www.spinics.net

Re: How to use scan-s2?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, Jan 26, 2009 at 5:43 PM, Mika Laitio <lamikr@xxxxxxxxxx> wrote:
> As an owner of cx24116 device you should know that it doesn't allow any AUTO
> settings, so you have to create an INI file with all parameters explicitly
> specifed (FEC, modulation, rolloff).
>
> I believe this is the main problem.
>
> Also, please take the latest scan-s2, I've done some changes especily for
> cx24116 cards.

Thanks for the hint, I will try to investigate this more.
I didn't know this because the old scan from dvb-apps have seemed to
find channels even with this simpler Satellite scan data that comes
withing dvb-apps for Astra.
To make a long story short, scan utility set specific FEC and rolloff parameters based on delivery type (DVB-S or S2) since the old interface (the one before S2API) didn't support specifying delivery type. Since S2API do support it, there is no need to play with other parameters, so AUTO parameters are used by default. You can always override those in INI file ofcause.


Could you or somebody else give me an example from the satellite conf file
where all those fields are filled in? I am little confused from those
parameters.
I don't have a dish to 19.2E, so can't help with that.
 


How about the channel data generated by the scan-s2 or scan with "-o vdr"
option. Should I also make some changes to those manually?
you can use scan-s2 output as is for VDR. It has more information than scan utility produce.


I think there must however be a bug either in scan-s2 or hvr-4000 S2API
driver, if it's will start scanning even if the given input data is
invalid. I mean that I think the driver and S2API should "hide away" the
differences between different S/S2 chipsets in a way that same data given
by the user space application should be acceptable for any card/s2-driver.

Is the bug in the scan-s2 not handling the error message from the driver
about using "AUTO" values, or is the bug in the driver not "correctly"
returning the error when all data needed is not set?
The bug is in S2API that doesn't return ANY error message at all :)
So the tuner is left locked on previous channel.
 
There are many things that can be done in driver to improve the situation, but I'll leave it to someone who has card with cx24116 chips.
 


Mika

_______________________________________________
linux-dvb users mailing list
For V4L/DVB development, please use instead linux-media@xxxxxxxxxxxxxxx
linux-dvb@xxxxxxxxxxx
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

_______________________________________________
linux-dvb users mailing list
For V4L/DVB development, please use instead linux-media@xxxxxxxxxxxxxxx
linux-dvb@xxxxxxxxxxx
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

[Linux Media]     [Video 4 Linux]     [Video Technology]     [Asterisk]     [Photo]     [Samba]     [Xorg]     [Xfree86]     [Devices]     [DVB Maintainer]     [Linux USB]