FW: CENTOS kernel 2.6.18

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi David

How about this?

I will try to upgrade my system to kernel 2.6.32.
But is there any good information to do it? So I will be able to do it.

Scott

-----Original Message-----
From: scott [mailto:scott@xxxxxxxx] 
Sent: Tuesday, December 22, 2009 8:01 PM
To: 'Linux filesystem caching discussion list'
Subject: RE:  CENTOS kernel 2.6.18

Hi Devid

Thank you for your reply.

> You really want something 2.6.32 based.  I whole slew of fixes to FS-Cache
and
> CacheFiles went in just before Linus cut 2.6.32.

I tried to upgrade with kernel 2.6.32 but it didn't work out. Server was not
backed on after recompiled and rebooted. So I tried to use kernel 2.6.30.10
and it went through. 

Is it possible to upgrade kernel 2.6.32 on CENTOS 5.3 installed linux?
I don't have confidence to do it.

> cachefilesd-0.8 and below will work with the RHEL-5 FS-Cache.  You need
> cachefilesd-0.9 for the CacheFiles that actually got upstream, and that
one
i> sn't backwardly compatible.  There was a massive rewrite between the
RHEL-5
> FS-Cache and the upstream FS-Cache.

I used cachefilesd-0.8 on kernel 2.6.18 and when I execute command, it
returned error messages as below.

cachefilesd[2987]: Failed to check object's in-use state: errno 95(Operation
not supported)

And it didn't start.

> What nfs-utils are you using?  Does dmesg show anything?

It is nfs-utils-2.1.1 and it has "fsc" option. I tested if it works on
kernel 2.6.30.10 and it was OK. But after I put kernel 2.6.18 back on
system, it doesn't let me use option "fsc". (I am sorry but I could not find
error messages for this.)

Here is my situation.
1. kernel 2.6.32		Not succeeded recompile it.
2. kernel 2.6.30.10		Succeeded recompile it. And everything work
very fine 			but it becames zombie under heavy traffic.
(under heavy 			NFS files transfer.)
3. kernel 2.6.18		Cachefilesd doesn't start. NFS doesn't start
with option 			"fsc" May be way to recompile kernel was
wrong. Kernel 			2.6.18 is a lot different from later than
kernel 2.6.30. . 

To use kernel 2.6.32 and 2.6.30 is risky for me. As long as kernel 2.6.18
may be able to handle with cachefiles, I really want to try it.
Unfortunately I could not succeed it on kenrnel2.6.18 yet and I need your
help. This server only needs to cache files from NFS server and no WRITE.
(only READ).

Please instruct me how to recompile kernel 2.6.18.

I hope you can help me and am so sorry to confuse you a lot.

Best regards


--
Linux-cachefs mailing list
Linux-cachefs@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/linux-cachefs

[Linux Resources]     [LARTC]     [Bugtraq]     [Yosemite Forum]     [Photo]

Powered by Linux