[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: parent transid verify failures on 2.6.39



Could I try your hack, pretty please? If there's any chance it could either resolve this problem

     http://www.mail-archive.com/linux-btrfs@xxxxxxxxxxxxxxx/msg10683.html ,

or at least restore the data from the filesystem, then I'd like to give it a go. Waiting for the new btrfsck is currently not an option for me :-)

It looks like your box is failing to read the extent allocation tree.
We don't allow the mount to proceed without that tree, but you don't
actually need it for a readonly mount (to copy things off).

Josef, is your hack just a mount option to make -o readonly skip the
extent allocation tree?

I can put this into my -o recovery patch and we can give it a try.


Here's the patch, you _have_ to mount -o readonly.  Basically what it does is
search all the mirrors and finds the one with the newest generation number and
just uses that one, assuming that it will be the closest one to what we want.
This has worked relatively well for the people who have used it, so hopefully it
will work for you.  Thanks,

Great, it works for me. I could mount the RAID0 root partition from an ArchLinux live CD (after patching, compiling and replacing the btrfs module first). Thank you very much!

My RAID1 /boot partition looks odd and mount froze (with an ooops) when I tried to access it this way. Fortunately, /boot doesn't matter that much, it will be easy to recover.

Andrej

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Linux Kernel]     [Linux SCSI]     [XFree86]

Add to Google Powered by Linux