Wireless bluetooth headset

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Hello.

I'd like to use my bluetooth headset in linux; I have successfully
paired and used it with my cell phone and an android tablet. But I
can't get mplayer in linux to output its sound there.

I have tried the test-audio script (in bluez-49.8/test) to
successfully establish a connection to the headset, but when I try
with mplayer, I get

# mplayer -ao alsa:device=btheadset file.mp3
...snip...
bt_audio_service_open: connect() failed: Connection refused (111)
[AO_ALSA] Playback open error: Connection refused
Failed to initialize audio driver 'alsa:device=btheadset'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video


Exiting... (End of file)

so there seems to be a connection problem (I have configured the
"btheadset" pcm in my .asoundrc:

pcm.btheadset {
type bluetooth
device "00:18:91:D0:7A:24"
profile "auto"
}
ctl.btheadset {
type bluetooth
}
)

When I tried simple-agent to register the PIN of the set, I get

# ./simple-agent hci0 $HEAR01
Creating device failed: org.bluez.Error.AlreadyExists: Already Exists

so the PIN must already be registered.

What must I do next? This is under Slackware linux, so I can't use
gnome or KDE tools; I have successfully used the set in Ubuntu by the
way).

Thanks!

-- 
F. Delente
--
To unsubscribe from this list: send the line "unsubscribe linux-bluetooth" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Bluez Devel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Bluez Devel]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Devices]     [Big List of Linux Books]

Add to Google Powered by Linux