Re: Issue with the priority of the sound cards using rtirq

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On 05/01/12 08:07, Ralf Mardorf wrote:
Doesn't work either:(.

spinymouse@precise:~$ sudo gedit /etc/default/rtirq
spinymouse@precise:~$ sudo /etc/init.d/rtirq stop
spinymouse@precise:~$ sudo /etc/init.d/rtirq start
Setting IRQ priorities: start [rtc] irq=8 pid=92 prio=90: OK.
Setting IRQ priorities: start [hdsp] irq=18 pid=85 prio=85: OK.
Setting IRQ priorities: start [hdsp] irq=18 pid=89 prio=84: OK.
Setting IRQ priorities: start [hdsp] irq=18 pid=649 prio=83: OK.
Setting IRQ priorities: start [hdsp] irq=18 pid=1163 prio=82: OK.
Setting IRQ priorities: start [ice1] irq=20 pid=656 prio=80: OK.
Setting IRQ priorities: start [ice1] irq=21 pid=688 prio=79: OK.
Setting IRQ priorities: start [ohci_hcd] irq=16 pid=81 prio=75: OK.
Setting IRQ priorities: start [ohci_hcd] irq=17 pid=83 prio=74: OK.
Setting IRQ priorities: start [ohci_hcd] irq=17 pid=87 prio=73: OK.
Setting IRQ priorities: start [ehci_hcd] irq=19 pid=79 prio=75: OK.
Setting IRQ priorities: start [i8042] irq=1 pid=91 prio=70: OK.
spinymouse@precise:~$ sudo /etc/init.d/rtirq status

   PID CLS RTPRIO  NI PRI %CPU STAT COMMAND	
    92 FF      90   - 130  0.0 S    irq/8-rtc0	
    85 FF      85   - 125  0.0 S    irq/18-ohci_hcd	
    89 FF      84   - 124  0.0 S    irq/18-ohci_hcd	
   649 FF      83   - 123  0.0 S    irq/18-snd_hdsp	
  1163 FF      82   - 122  0.8 S    irq/18-nvidia	
   656 FF      80   - 120  0.0 S    irq/20-snd_ice1	
   688 FF      79   - 119  0.0 S    irq/21-snd_ice1	
    79 FF      75   - 115  0.0 S    irq/19-ehci_hcd	
    81 FF      75   - 115  0.1 S    irq/16-ohci_hcd	
    83 FF      74   - 114  0.0 S    irq/17-ohci_hcd	
    87 FF      73   - 113  0.0 S    irq/17-ohci_hcd	
    91 FF      70   - 110  0.0 S    irq/1-i8042	
    20 FF      50   -  90  0.0 S    irq/9-acpi	
    68 FF      50   -  90  0.0 S    irq/22-ahci	
   256 FF      50   -  90  0.0 S    irq/14-pata_ati	
   257 FF      50   -  90  0.0 S    irq/15-pata_ati	
   290 FF      50   -  90  0.0 S    irq/22-firewire	
   570 FF      50   -  90  0.0 S    irq/7-parport0	
  1008 FF      50   -  90  0.0 S    irq/43-eth0	
     3 TS       -   0  19  0.2 S    ksoftirqd/0	
     9 TS       -   0  19  0.2 S    ksoftirqd/1	

spinymouse@precise:~$ grep RTIRQ_NAME_LIST /etc/default/rtirq
#RTIRQ_NAME_LIST="rtc snd usb i8042"
#RTIRQ_NAME_LIST="rtc hdspm ice1712 snd usb i8042"
RTIRQ_NAME_LIST="rtc hdsp ice1 usb i8042"

Looks good to me, except for the two ohci_hcd and the nvidia threads. I don't see those when you start rtirq but they are there when you query rtirq's status. Weird. Same issue after a reboot? And this hdspm device, is that an extension card (PCI, PCIe)? If so you might want to try another slot because having it to share the same IRQ as your GPU isn't ideal. And maybe you could post or pastebin your complete /etc/default/rtirq file.

Best,

Jeremy
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@xxxxxxxxxxxxxxxxxxxx
http://lists.linuxaudio.org/listinfo/linux-audio-user


[Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Media]     [Kernel]     [Photo Sharing]     [Gimp]     [Yosemite News]     [Linux Media]

Add to Google Powered by Linux