Re: Start of audio cut off on USB DAC

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



--- On Fri, 2/3/12, Clemens Ladisch <clemens@xxxxxxxxxx> wrote:

> The device needs that long to synchronize to the computer's
> clock.
>
> > the USB DAC works fine in Windows.
>
> I'd guess the Windows driver sends some silence before the
> start of the
> file.
>
> > Any ideas on how I can fix this?
>
> Use something to allow mixing (PulseAudio, dmix, whatever),
> and play
> silence before the actual playback starts.
>
> > tried using JACK (with ALSA), but it doesn't make any
> difference.
>
> In theory, Jack runs continuously, so this shouldn't
> happen.  Does Jack
> get started for each file?
>
>
> Regards,
> Clemens

It looks like I misidentified what the problem is. I've noticed that a fraction of a second of music is missing from the start of some of my files, but when I concatenated two files with sox, it didn't make any difference.

Most of my music is ripped from CDs, so the sample rate is 44.1 kHz. For two files I have where the effect is particularly noticeable, I found that if I convert the sample rate to 48 or 96 kHz in sox and then play the files, they sound correct. Even if I convert them back to 44.1 kHz after this, they still sound correct.

I've started jack at 44.1, 48 and 96 kHz, along with 16 bit and 24 bit, and tried all of the dithering settings on the -s option of jackd. I get the same problem with all of the settings I've tried. I've also tried to get other music players to do sample rate conversion, but I've only been able to make the problem go away using sox.

Other than using sox to convert my entire music library to 48 kHz, is there something else I can try?

Phil
_______________________________________________
Linux-audio-user mailing list
Linux-audio-user@xxxxxxxxxxxxxxxxxxxx
http://lists.linuxaudio.org/listinfo/linux-audio-user


[ALSA Users]     [ALSA Devel]     [Linux Media]     [Kernel]     [Online Dating]     [Photo Sharing]     [Gimp]     [Yosemite News]     [Video 4 Linux]

Add to Google Powered by Linux