Re: Unable To Jump To Undefined Symbol

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, Mar 14, 2006 at 07:16:30PM +0530, Deepak Pandey wrote:

> Hi, I got a compilation problem saying UNABLE TO JUMP TO UNDEFIND
> SYMBOL while compiling a code in which I tried to jump to a
> symbol(symbol_name) from a different file by an assembly instruction
> (j symbol_name).However I also declared the symbol as global(.globl
> symbol_name) but still it didnot worked.
You need to tell the assembler in the file which references the symbol
that it's out there.  Use extern, EXTRN or whatever directive your
assembler supports for this purpose.

> The Symbol was defined as follows:
> LEAF(symbol_name)
>       /*some assembly instructions*/
> END(symbol_name)
What assembler uses these syntactic constructs?

  Leslie

-- 
gpg --keyserver pgp.mit.edu --recv-keys 0x52D70289
http://nic-nac-project.de/~skypher/

Attachment: pgpq3R2JILIgo.pgp
Description: PGP signature


[Kernel Newbies]     [Security]     [Linux C Programming]     [Linux for Hams]     [DCCP]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]     [Video 4 Linux]

  Powered by Linux