Re: [PATCH 2/3] nbd: add support for feature negotiation
|[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]|
On 09/07/2011 06:30 PM, Paul Clements wrote:
Could you name this as NBD_SET_FLAGS, as that's more consistent with what it's really doing?
I named it differently intentionally, actually, because it should not use the flags field from the network protocol as is. Also, "features" sounds more like something that is optional, while unrecognized "flags" should probably cause a failure.
What about renaming the struct field and leaving this as NBD_SET_FEATURES or NBD_ENABLE_FEATURES?
Paolo -- To unsubscribe from this list: send the line "unsubscribe linux-api" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html