Re: pppd and DNS [WAS:Driver for 536ep-Modem does not compile]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Dear Jacques,

I tried your suggestions:

I put usepeerdns into /etc/ppp/options, I remove the ethernet-cable, I do $wvdial with Auto DNS = yes in /etc/wvdial.conf, and obtain

--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Wed Feb 29 17:38:23 2012
--> Pid of pppd: 8823
--> Using interface ppp0
--> local  IP address
--> remote IP address
--> primary   DNS address
--> secondary DNS address
--> Script /etc/ppp/ip-up run successful
--> Default route Ok.
--> warning, can't find address for ``
--> warning, address lookup does not work
--> Nameserver (DNS) failure, the connection may not work.

and no throughput through the connection. The search for is a DNS-check built into wvdial by SUSE. Even if I remove /etc/resolv.conf it is immediately restored by the NetworkManager with the old entries:

search localdomain site

(the DNS of my DSL). Only if I replace those entries with a static nameserver, then I get a working connection with wvdial. You said the other day, that your resolv.conf for ppp sits in /var/run/ppp, but such a directory does not exist in SUSE 11.4, and if I create it, it has no effect. A search for other resolv.conf files on my system showed me 1) a file /var/run/ppp_resolv.conf.ppp0 which contains the above DNS adresses:


If I add a valid DNS address to this file instead of /etc/resolv.conf it is ignored, and still no working connection.

2) and a file /var/adm/netconfig/md5/etc/resolv.conf which contains

f40cb6e6e9d7c60cead0424139a8722a  -

I have the same impression as Ludwig that this is a SUSE-issue.


On Wed, 29 Feb 2012, Jacques Goldberg wrote:

Dear Ludwig,

Please forgive me to remind here, since I do not know you, that wvdial/wdialconf are not programs that operate the communication but rather friendly utilities that prepare the parameters (data) for the real program which does the work, pppd.

Now please can you tell us if there is or not a line usepeerdns in your file /etc/ppp/options

If there is not, please add that line.

Then please try to connect to your analog modem ISP with wvdial and Auto DNS = yes, do not worry for what there is or not in /etc/resolv.conf because in this case pppd should NOT use /etc/resolv.conf, disconnect the cable from DSL to PC to make sure that you use the analog modem, and try to surf the Web, like Google or others. Does it work?

If it works (it should), reconnect your DSL, make it work by adding the DSL DNS in /etc/resolv.conf if necessary (see Note) and give the following commands in a separate window as superuser (the first takes time), while wvdial (pppd) is still running: updatedb ,then this long composite command for f in `locate resolv.conf* `;do echo $f;cat $f;done so that you can see the contents of the various resolv.conf present on your computer.

Note: if your DSL box is not old, and I am sure you were given a brand new one since DSL is new in your place, configure your PC (Linux) for the DSL connection to take DNS's from the DSL box (do not define /etc/resolv.conf and make it clear in the network s\manager definitions, no local name server, no local DNS). Your DSL box normally comes configured such that the DSL box takes itself automatically the DNS addresses from the network. You may want,and even need, to check that your DSL box is configured like that. That way you should not hear of DNS's any more once you have usepeerdns in your /etc/ppp/options .



n 02/29/012 02:00 PM, Ludwig Gebauer wroteresolv.conf

With "Auto DNS = yes" in wvdial.conf, DNS addresses show up in the wvdial protocol, when running wvdial (ISP: ), whether network manager is activated or not. wi And whether network manager is activated or not, I have to edit resolv.conf manually. Since a few weeks, DSL exists here in my village, 12 km afar from Brunswick (so much about the highly industrialisated etc. country Germany), and with my DSL _modem_ (not a modem _router_!) I have the same effect: DNS addresses must be transferred manually to resolv.conf. Seems to be an openSUSE 11.4 issue.

Wolfgang Junker                       Habsburgerallee 12
                                      D-52064 Aachen
                                      Tel. 0241/1899787

[Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux