Re: intel 537 with kernel 3.1.x

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Patrick,

>> If there is anything I can ever do to repay you please let me know!

Yes, indeed, you can repay us by attentively redeading my litterature on the Intel modems subject at http://vouters.dyndns.org/Intel/Intel-Readme.html and give us your feedback upon it.

What we do expect are your detailled impressions about this document clarity and informations completeness.

Post-scriptum : if you are looking for informations on either Linux, Unix, OpenVMS or Windows, you may refer to another side of my Web site at http://vouters.dyndns.org/tima/ If, even better, you mail me with technical subjects I can study and document, you'll make the worldwide IT community happy.

Yours truly,
Philippe

Le 04/01/2012 14:46, Patrick Boyadjian a écrit :
Brilliant, it works!

Philippe and Antonio, thank you so much for your support in this regard!

If there is anything I can ever do to repay you please let me know!

Regards,
Patrick



On Wed, Jan 04, 2012 at 12:27:39PM +0100, Philippe Vouters wrote:
My work ought to support your modem.
[philippe@victor ~]$ grep e159:0001 intel-536-537/*
intel-536-537/makefile_537:     vendor_device_ids[0]="e159:0001";\

The alternative to modifying the bash files is to download
http://vouters.dyndns.org/Intel/intel-536EP-537EP_2012_01_04.tar.bz2

Please reply whether you are fully satisfied or not.

Regards,
Philippe

Le 04/01/2012 04:03, Patrick Boyadjian a écrit :
Thanks for the swift reply Antonio.

Well originally I had a conexant chipset for a HCF modem that the linuxant group had drivers for, however those drivers ONLY worked on pre 3.x kernels so they broke when I upgraded.  Dev team from Linuxant has informed me they are aware of the API break in the driver for the newer kernel and say they should fix it sometime soon.  Meanwhile I dug up the Intel modem you see below to try and get it to work.

So short answer I never should have upgraded!! :)

Regards,
Patrick



On Tue, Jan 03, 2012 at 07:47:12PM -0600, Antonio Olivares wrote:
Patrick,

I am unsure if that modem in particular is served by Phillipe's
driver.  IT does not seem to be a true INTEL 537 modem :(
However, there was a recent update to the driver since it was failing
to build up in Ubuntu and it was working fine in Fedora 15.  Did you
make sure that you got the latest driver available from Phillipe's
website?

Oops sorry, you did get the latest one. Maybe Phillipe can comment
here to make sure that maybe something went wrong, or that it may be
specific to 537 modem, since the driver also works with 536 Intel
based modems.

Regards,


Antonio

BTW,
since you have experience with linux since the Red Hat days, did you
get to use this particular modem before?  If you did and the drivers
worked, I see no reason why the modem should not work with the newer
kernels.


On Tue, Jan 3, 2012 at 7:24 PM, Patrick Boyadjian
<patrick@xxxxxxxxxxxxxxxxxxxxxxx>   wrote:
Hi,

This is my first attempt to contact this group so apologize in advance if I=  don't provide sufficient information.

I'm not exactly a newbie to linux and Fedora since I've used it back when i= t was called red hat...I've upgraded to Fedora 16 recently and boy how thin= gs have changed!  Anyways, here is where I'm at:

lspci shows my modem as:
01:01.0 Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISD= N interface

scanModem details as:
For candidate card in slot 01:01.0, firmware information and bootup diagnos= tics are:
PCI slot       PCI ID          SubsystemID     Name
----------     ---------       ---------       --------------
01:01.0        e159:0001       8086:0003       Communication controller: Ti=
ger Jet Network Inc. Tiger3XX Modem/ISDN interface

Modem interrupt assignment and sharing:
--- Bootup diagnostics for card in PCI slot 01:01.0 ----
[    0.109098] pci 0000:01:01.0: [e159:0001] type 0 class 0x000780
[    0.109120] pci 0000:01:01.0: reg 10: [io  0xa000-0xa0ff]
[    0.109133] pci 0000:01:01.0: reg 14: [mem 0xf1004000-0xf1004fff]
[    0.109200] pci 0000:01:01.0: supports D2
[    0.109203] pci 0000:01:01.0: PME# supported from D0 D2 D3hot D3cold
[    0.109209] pci 0000:01:01.0: PME# disabled

The PCI slot 01:01.0 of the modem card may be disabled early in a bootup process,  but then enabled later. If modem drivers load but the  modem is not responsive, read DOCs/Bootup.txt about possible fixes= .
Send dmesg.txt along with ModemData.txt to discuss@xxxxxxxxxxxxx if help is needed.



Predictive  diagnostics for card in bus 01:01.0:
        Modem chipset  detected on
NAME=3D"Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISD= N interface"
CLASS=3D0780
PCIDEV=3De159:0001
SUBSYS=3D8086:0003
IRQ=3D11
HDA2=3D00:1b.0
IDENT=3DINTEL537

For candidate modem in:  01:01.0
   0780 Communication controller: Tiger Jet Network Inc. Tiger3XX Modem/ISD= N interface
      Primary device ID:  e159:0001
Support type needed or chipset:        INTEL537


So I visited http://vouters.dyndns.org/Intel/ and heeded Philippe's note to=
:


If you execute a 3.x.y kernel, download:

../Intel/intel-536EP-537EP_2011_12_11.tar.bz2<http://vouters.dyndns.org/Int=
el/intel-536EP-537EP_2011_12_11.tar.bz2>



...and continued to untar and try to build.

Issuing make clean and make 537 seem to work with a warning:

[root@pb3000 intel-536-537]# make clean
cd coredrv; make clean
make[1]: Entering directory `/root/intel-536-537/coredrv'
rm -f *.ko .*.o.cmd *.mod.c .*.ko.cmd *.o *~ core Module.* modules.* rm -rf .tmp_versions
make[1]: Leaving directory `/root/intel-536-537/coredrv'
rm -f *.o *.ko
[root@pb3000 intel-536-537]# make 537
cd coredrv; make clean
make[1]: Entering directory `/root/intel-536-537/coredrv'
rm -f *.ko .*.o.cmd *.mod.c .*.ko.cmd *.o *~ core Module.* modules.* rm -rf .tmp_versions
make[1]: Leaving directory `/root/intel-536-537/coredrv'
rm -f *.o *.ko
   Module precompile check
   Current running kernel is: 3.1.6-1.fc16.i686
   /lib/modules...   autoconf.h exists
diff: /boot/vmlinuz.autoconf.h: No such file or directory
   autoconf.h matches running kernel
diff: /boot/vmlinuz.version.h: No such file or directory
   version.h matches running kernel
make[1]: Entering directory `/root/intel-536-537'
Building for 537
3.1.6-1.fc16.i686
make[2]: Entering directory `/root/intel-536-537/coredrv'
make -C /lib/modules/3.1.6-1.fc16.i686/build M=3D/root/intel-536-537/coredr= v modules
make[3]: Entering directory `/usr/src/kernels/3.1.6-1.fc16.i686'
  CC [M]  /root/intel-536-537/coredrv/coredrv.o
  CC [M]  /root/intel-536-537/coredrv/clmmain.o
  CC [M]  /root/intel-536-537/coredrv/rts.o
  CC [M]  /root/intel-536-537/coredrv/task.o
  CC [M]  /root/intel-536-537/coredrv/uart.o
  CC [M]  /root/intel-536-537/coredrv/wwh_dflt.o
  CC [M]  /root/intel-536-537/coredrv/locks.o
  CC [M]  /root/intel-536-537/coredrv/softserial_io.o
  CC [M]  /root/intel-536-537/coredrv/softserial_ioctl.o
  CC [M]  /root/intel-536-537/coredrv/softserial.o
  CC [M]  /root/intel-536-537/coredrv/afedsp_int.o
  LD [M]  /root/intel-536-537/coredrv/Intel537.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: could not find /root/intel-536-537/coredrv/.537core.lib.cmd for /r= oot/intel-536-537/coredrv/537core.lib
  CC      /root/intel-536-537/coredrv/Intel537.mod.o
  LD [M]  /root/intel-536-537/coredrv/Intel537.ko
make[3]: Leaving directory `/usr/src/kernels/3.1.6-1.fc16.i686'
make[2]: Leaving directory `/root/intel-536-537/coredrv'
make[1]: Leaving directory `/root/intel-536-537'
[root@pb3000 intel-536-537]#


However, make install fails complaining about kernel version:

[root@pb3000 intel-536-537]# make install
make[1]: Entering directory `/root/intel-536-537'
rm -f /usr/sbin/hamregistry.bin
bash 537_inst
running kernel 3.1.6-1.fc16.i686
unsupported kernel version: only 2.4.x and 2.6.x are supported
make[1]: *** [install] Error 1
make[1]: Leaving directory `/root/intel-536-537'
[root@pb3000 intel-536-537]#


Am I missing something?  Any help here is super appreciated.

Patrick




--
Philippe Vouters (Fontainebleau/France)
URL: http://vouters.dyndns.org/


--
Philippe Vouters (Fontainebleau/France)
URL: http://vouters.dyndns.org/


[Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux