Re: agrsm-tools.deb update.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


We can conclude that actual modem activation is the problem.
Unfortunately, since there is a large Closed Source component,
the usual Linux troubleshooting tools cannot be applied.

Later when I'm under Linux, I'll send you a procedure to test.
But I'm not very hopeful.
The simplest route would be to shop for a Controller Chipset modem,
as constrasted to a winmodem.

MarvS

On Thu, Sep 8, 2011 at 12:38 AM, Ian Smith <ismith@xxxxxxxxxxxxxx> wrote:
> Marvin,
>
> I tried again, and I thought it had worked - after the wvdialconf
> command, I had a list of S1 .... and on the same line the command line
> prompt - but I could use the mouse, and clicked in another window. I
> went back to the terminal window, pressed <RETURN>, and the screen froze
> again. I waited maybe 30seconds before switching the laptop off.
>
> Is there anything else to try?
>
> Kind Regards,
>
>
> Ian
>
> On 31/08/11 16:06, Marvin Stodolsky wrote:
>> Ian,
>>
>> RE: am I supposed to be doing something at the moment?
>> Following Jacques suggestion:
>> re:  >>>> Once only,   sudo  ln  -sf  /dev/ttyAGS3   /dev/ttyS16
>>>>>> S16 exists and is never used, so choose S16  and link with a force  (the f
>>>>>> in -sf)  to override its current definition
>>>>>> Try wvdialconf again to see if before hanging (or not) it will find your
>>>>>> modem as /dev/ttyS16  or not.
>> ====
>>
>> The test we would like your to do is:
>> $ sudo ./unloading
>> $ sudo modprobe agrserial
>> to load the drivers.
>> $ sudo ln -sf /dev/ttyAGS3   /dev/ttyS16
>> so that wvdialconf will follow /dev/ttyS16 --> /dev/ttyAGS3  , the real port.
>> Then once more
>> $ sudo wvdialconf wvtest.txt
>>
>> The possibility Jacques raises is that something other than the query
>> to /dev/ttyAGS3
>> is causing your System to hang.  If it still hangs under this test, we
>> know modem is indeed the culprit.
>>
>> MarvS
>>
>>
>> On Wed, Aug 31, 2011 at 10:01 AM, Ian Smith <ismith@xxxxxxxxxxxxxx> wrote:
>>> Jacques,
>>>
>>> My apologies, but am I supposed to be doing something at the moment? I
>>> would hate to think through my oversight I am causing a delay!
>>>
>>> Kind Regards,
>>>
>>>
>>> Ian
>>>
>>> On 29/08/11 16:50, Jacques Goldberg wrote:
>>>> Thanks Marv for the clarification.
>>>> Please look at this relevant section circa lines 485 ssq of file
>>>> wvmodemscan.cc in wvdial 1.61:
>>>> static int fileselect(const struct dirent *e)
>>>> {
>>>>     return !strncmp(e->d_name, "ttyS", 4)       // serial
>>>>        || !strncmp(e->d_name, "ttyLT", 5)       // Lucent WinModem
>>>>        || !strncmp(e->d_name, "ttyACM", 6)      // USB acm Modems
>>>>        || !strncmp(e->d_name, "ttyUSB", 6)      // Modems on USB RS232
>>>>        || !strncmp(e->d_name, "ircomm", 6)      // Handys over IrDA
>>>>        || !strncmp(e->d_name, "ttySL", 5);      // SmartLink WinModem
>>>>
>>>>         // (no internal ISDN support)   || !strncmp(e->d_name, "ttyI", 4);
>>>> }
>>>>
>>>> ttyS is the first accepted pattern.
>>>> My suspicion about the need in this version for the end of ttyS to be
>>>> completed with digits, hence the suggestion to try S16, comes from the
>>>> fifth pattern with ttySL. Who needs it if ttyS followed by letter L is
>>>> treated with the first pattern?
>>>>
>>>> Jacques
>>>>
>>>>
>>>> On 08/29/2011 05:13 PM, Marvin Stodolsky wrote:
>>>>> Just to clarify issues
>>>>>
>>>>> 1) loading agrmodem is typically trouble free
>>>>>
>>>>> 2) loading agrserial dynamically creates /dev/ttyAGS3 (so terribly
>>>>> named by Agere)
>>>>>
>>>>> 3) the scripts provided by my agrsm-tools package
>>>>> a) preload agrmodem, upon
>>>>> $ sudo modprobe agrserial
>>>>> b) create the /dev/ttySAGR --> /dev/ttyAGS3   symbolic link, for later
>>>>>  use in the wvdialconf test.
>>>>>
>>>>> It is when modem port usage is actually begun, for example by
>>>>> wvdialconf, that some systems have a conflict.  This seems to be
>>>>> happening on Ian's system,
>>>>> as all the /dev/ttySn (n a number) are first queried.    /dev/ttySAGR
>>>>> would be next in line,
>>>>> and than is when the hang seems to occur.
>>>>>
>>>>> Certain doing Jacques suggested test with the /devttyS16 -->
>>>>> /dev/ttyAGS3 symbolic link is worthwhile, though I expect this is
>>>>> Resource Conflict case that is difficult to resolve,
>>>>>
>>>>> MarvS
>>>>>
>>>>>
>>>>>
>>>>> On Mon, Aug 29, 2011 at 9:44 AM, Jacques Goldberg
>>>>> <Jacques.Goldberg@xxxxxxx> wrote:
>>>>>> Ian,
>>>>>>
>>>>>> I am getting old. I just suddenly remember that I got mad, long ago, trying
>>>>>> to help somebody, with wvdialconf hanging up on my own computer with no
>>>>>> modem installed. I got rid of the problem using an older version  of
>>>>>> wvdialconf. The difference was that the older would only scan /dev/ttyS*
>>>>>> addresses while the newer one also looked for USB, ACM, ISDN and perhaps
>>>>>> other devices.
>>>>>> Remembering that, I just downloaded the source code for wvdialconf.
>>>>>> Analyzing it I already have three trivial questions to ask you, please
>>>>>> forgive me for such stupid questions:
>>>>>> 1-Which version are you using? The command       wvdialconf  --version
>>>>>> gives the answer
>>>>>> 2-When the computer hangs, just where you at least tried to give a carriage
>>>>>> return, have you tried to give   CTRL C  (that is hit C while holding down
>>>>>> the CTRL key)?
>>>>>> 3-This one comes from an other user: have you tried to wait, doing nothing
>>>>>> after having started  wvdialconf , for at least one timed minute, a feeling
>>>>>> of the time elapsed is not enough,  just to make sure that it does not come
>>>>>> back to life without intervention? That user had observed that the additions
>>>>>> beyond the basic /dev/ttyS* pattern cause wvdialconf to silently work for
>>>>>> quite a bit of time before reporting null results.
>>>>>>
>>>>>> >From the photo there is  something puzzling. It shows a device named
>>>>>> /dev/ttyAGS3  (yellow), probably created when loading the driver, linked to
>>>>>> an object /dev/ttySAGR  for the obvious and unique purpose of respecting the
>>>>>> old convention of naming serial ports according to
>>>>>> /dev/ttyS<something> . If my hint that wvdialconf hangs AFTER having
>>>>>> completed scanning for /dev/ttyS* , and therefore having failed to find
>>>>>> /dev/ttySAGR, I can see at least two reasons: the driver does not correctly
>>>>>> create /dev/ttyAGS3 , or,  the version of wvdialconf which you use insists
>>>>>> that /dev/ttyS<something>  requires a number withing some range for
>>>>>> <something>.
>>>>>>
>>>>>> Elder readers who remember the early days of the Lucent driver LTMODEM
>>>>>> from which is some way your driver is derived will understand why in your
>>>>>> place I would give this a try:
>>>>>> Once only,   sudo  ln  -sf  /dev/ttyAGS3   /dev/ttyS16
>>>>>> S16 exists and is never used, so choose S16  and link with a force  (the f
>>>>>> in -sf)  to override its current definition
>>>>>> Try wvdialconf again to see if before hanging (or not) it will find your
>>>>>> modem as /dev/ttyS16  or not.
>>>>>>
>>>>>> Jacques
>>>>>>
>>>>>>
>>>>>> On 08/29/2011 11:35 AM, Ian Smith wrote
>>>>>>
>>>>>> Marvin,
>>>>>>
>>>>>> Up to the wvdialconf command, the text below was from the console -
>>>>>> after the wvdialconf command, the laptop froze - and I hav
>>>>>>
>>>>
>>
>



[Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux