Re: Error on installing modem file

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Ian

The core problem currently is that the code is not compiling under
current kernels, per example below.
No one currently following this List seems to have the adequate skills
to update this Open Source section of the code.
If you must use a modem, we would recommend buying some Controller Chipset type
which are supported fully by Linux serial drivers.  But don't but
anything that doesn't promise Linux support.

MarvS

$ sudo make
make -C /lib/modules/2.6.38-10-generic/build
M=/usr/src/pkg/agrsm/1040/agrsm-2.6.32 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.38-10-generic'
  CC [M]  /usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.o
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c: In function
‘x_usb_buffer_alloc_atomic’:
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c:586:2: error:
implicit declaration of function ‘usb_buffer_alloc’
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c:586:2: warning:
return makes pointer from integer without a cast
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c: In function
‘x_usb_buffer_alloc_kernel’:
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c:590:2: warning:
return makes pointer from integer without a cast
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c: In function
‘x_usb_buffer_free’:
/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.c:595:2: error:
implicit declaration of function ‘usb_buffer_free’
make[2]: *** [/usr/src/pkg/agrsm/1040/agrsm-2.6.32/agrsoftmodem.o] Error 1
make[1]: *** [_module_/usr/src/pkg/agrsm/1040/agrsm-2.6.32] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.38-10-generic'
make: *** [default] Error 2


On Mon, Aug 8, 2011 at 12:56 PM, Antonio Olivares
<olivares14031@xxxxxxxxx> wrote:
> Ian,
>
> I believe that the errors occuring is that there is a reason :)  The
> reason being that the driver you are trying to install is the
> incorrect one.  You need the agrsm-11c11040 modem driver:
>
> http://linmodems.technion.ac.il/packages/ltmodem/11c11040/agrsm-11c11040_20091225_i386.deb
>
> + the agrsm tools:
> http://linmodems.technion.ac.il/packages/ltmodem/11c11040/agrsm-tools_0.0.1_all.deb
>
> But like I have mentioned before there have been no success reports as
> of late(with newer kernels >= 2.6.31 :(
>
> Marv can advise you what to do in this case, if there are updates to
> the modem code, but you can try them out and report back with the
> errors/error messages that you encounter.
>
> Regards,
>
> Antonio
>
> On Mon, Aug 8, 2011 at 11:48 AM, Ian Smith <ismith@xxxxxxxxxxxxxx> wrote:
>> Antonio,
>>
>> Many thanks for your help. Both packages (the driver and the tools)
>> still complain about the files
>>
>> "E: agrsm048pci-2.1.60:wrong-file-owner-uid-or-gid".
>>
>> Is this correct that these errors occur?
>>
>> Kind Regards,
>>
>>
>> Ian
>>
>>
>> On 08/08/11 17:29, Antonio Olivares wrote:
>>> Ian,
>>>
>>> scanModem does report what you have mentioned:
>>>
>>> Codec: LSI ID 1040
>>> Address: 1
>>> MFG Function Id: 0x2 (unsol 1)
>>> Vendor Id: 0x11c11040
>>> Subsystem Id: 0x11c10001
>>> Revision Id: 0x100200
>>> Modem Function Group: 0x1
>>>
>>>  The audio card hosts a softmodem chip:  0x11c11040
>>>
>>> The softmodem chip 11c11040 is hosted on the Subsytem of the High
>>> Definition Audio card,
>>> and is supported by the AgereSystems/LSI driver pair agrmodem +
>>> agrserial, which is provided by
>>> the most current package agrsm-11c11040-version at
>>> http://linmodems.technion.ac.il/packages/ltmodem/11c11040/
>>>
>>> But it mentions the most current agrsm-11c11040-version which is
>>> referenced below:
>>>
>>> 11c11040 (on HDA audio cards)
>>>
>>> 2.6.31  agrsm-11c11040_20091225_i386.deb
>>>
>>>    All available at:
>>> http://linmodems.technion.ac.il/packages/ltmodem/11c11040/
>>>
>>> Additionally you are encouraged to get the agrsm-tools package
>>> automation & testing                    agrsm-tools_0.0.1_all.deb
>>>
>>> There are difficulties though, as there have been no success reports
>>> with newer kernels :(  But you may try them out and report back with a
>>> report.
>>>
>>> Regards,
>>>
>>>
>>> Antonio
>>>
>>>
>>> On Mon, Aug 8, 2011 at 11:21 AM, Ian Smith <ismith@xxxxxxxxxxxxxx> wrote:
>>>> Antonio,
>>>>
>>>> Many thanks for such a quick reply.
>>>>
>>>> I have attached the file as requested.
>>>>
>>>> Kind Regards,
>>>>
>>>> Ian
>>>>
>>>> On 08/08/11 17:17, Antonio Olivares wrote:
>>>>> Ian,
>>>>>
>>>>> Would you mind sending us ModemData.txt?  It would help determine if
>>>>> the agrsm048pci-2.1.60_20100316.deb package is the right one for the
>>>>> job.
>>>>>
>>>>> Regards,
>>>>>
>>>>> Antonio
>>>>>
>>>>> On Mon, Aug 8, 2011 at 11:00 AM, Ian Smith <ismith@xxxxxxxxxxxxxx> wrote:
>>>>>> Sirs,
>>>>>>
>>>>>> I am trying to get my fax modem working, and used the latest version of
>>>>>> scanModem (which complained about being 27weeks old), and this
>>>>>> instructed me to download the latest file from
>>>>>> http://linmodems.technion.ac.il/packages/ltmodem/11c11040/ - so I selected
>>>>>> agrsm048pci-2.1.60_20100316_i386.deb
>>>>>> <http://linmodems.technion.ac.il/packages/ltmodem/11c11040/agrsm048pci-2.1.60_20100316_i386.deb>
>>>>>> as this had the latest file date, and appeared to be a formal release.
>>>>>>
>>>>>> When I used Ubuntu Software Centre to install it, I got errors stating
>>>>>> that the "package was of bad quality" and in more detail had the
>>>>>> following error possibly for each file "E: agrsm048pci-2.1.60:
>>>>>> wrong-file-owner-uid-or-gid".
>>>>>>
>>>>>> Where can I get a more up to date version of scanModem? And is there a
>>>>>> version of the software for my modem that I can see is safe to install?
>>>>>>
>>>>>> Thank you for your help.
>>>>>>
>>>>>> Kind Regards,
>>>>>>
>>>>>> Ian
>>>>>>
>>>>>>
>>>
>>
>



[Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux