Re: How to configure slmodem for PRI

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Ahmed,

slmodem, like most of the other soft modems, works at a sample rate of 9600/s. A PRI works at 8000 samples/s.

Steve


On 05/19/2011 10:56 PM, Antonio Olivares wrote:
Ahmed,

I apologize for not knowing  about PRI as to know how to help you.  I
am forwarding your message to list Linmodems discuss@xxxxxxxxxxxxx as
some other folks might know more and be able to help you.

Regards,

Antonio

On 5/19/11, Ahmed Munir<ahmedmunir007@xxxxxxxxx>  wrote:
Hi,

Need to know, which parameters or commands required for configuring an ISDN
PRI? Where I'm trying to use PRI single channel as modem one. My commands
are listed down below and as I try to run an application I'm getting a
message "No Carrier". The application I'm using is Qpage for paging
messages.

modem=ttya
    device=/dev/ttySL1
    initcmd=ATZ=E1Q0+FCLASS=0
service=abc
    device=ttya
    baudrate=9600
    parity=none
    maxtries=3
    maxmsgsize=255
    maxpages=9
    allowpid=true
    phone=14089612819

The way I'm using slmodem is that I'm binding softmodem with each PRI
channel as listed below;
slmodemd -c=USA /dev/dahdi/1

In return it creates a softlink i.e. /dev/ttySL1. Further added, my above
configuration is working fine on us robotics usbmodem.


Please assist me in this problem, I'm stuck in this problem for many days.

--
Regards,

Ahmed Munir




[Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux