Re: Mehdi, Iran kernel 2.6.28-11-generic

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Mehdi,

in your /etc/wvdial.conf
there is a line:    Stupid Mode = yes
This aborts negotiations between your modem and the Internet Provider.
 This negotation sets a few variables, depending on line quality.
Thus it is preferable Not to use it by:
# Stupid Mode = yes
However it is indeed necessary for some Internet Providers.

If the modem cannot be made to work under 9.04
you can try installing the old  8.04.1 kernel in your current 9.04 installation,
and try booting under it and testing the modem.  Typically
Ubuntu/Linux is backward compatible to older kernels over quite a
range of kernels.  It can do no harm to thus test.

MarvS



On Wed, Apr 6, 2011 at 6:27 PM, the mass <massreg@xxxxxxxxx> wrote:
> Antonio,
>
> Unfortunately I don't have any other version of ubuntu except 8.04.1
> and 9.04 available now.
>
> I installed the daemon (using deb packages) but still couldn't get the
> modem working in 9.04
>
> By the way, what is dkms?
>
>
> Marvin,
> Do you mean "Stupid Mode = yes"?
> As I checked the man page but I couldn't find such option.
> If so, I think I didn't have that option before and added it for
> troubleshooting. I think it is useful when you have connected to the
> remote host but my modem doesn't even dial!
>
>
>
> To install the modem, I had been restarting the computer going from
> Linux to Windows and vise versa, you know how it like :)
> Finally I wiped 9.04 out and Installed 8.04.1, I can access 9.04 using
> the LiveCD.
>
> Anyway I don't know it is a bug in the kernel or what. 8.04.1 kernel
> is 2.6.24-19-generic and has no problem.
>
>
> And finally thanks a lot for your support, at least I could use the
> Internet in 8.04.1 and I prefer 8.04.1 with Internet to 9.04 without
> Internet. I really appreciate your help.
>
> Sincerely,
> Mehdi
>
> On 4/6/11, Marvin Stodolsky <marvin.stodolsky@xxxxxxxxx> wrote:
>> RE: Âsl-modem-src
>> This isn't needed, as the audio+modem driver is snd-hda-intel and is
>> included in the Linux distributions.
>>
>> Only the slmodemd helper is needed, provided in the sl-modem-daemon package.
>> The including scripts should activate the modem on bootup, which you
>> can test with:
>> $ sudo wvdialconf Âmytest
>> IF you merely do
>> $ sudo wvdialconf
>> your current /etc/wvdial.conf would be overwritten. ÂSo be careful
>>
>> Also do a test commenting out the:
>> Stupid Modem=yes
>>
>> Your local phone company or Linux group may be able to provide
>> information on the optimal country code.
>> With installation of a sl-modem-dameon package, the COUNTRY
>> specification site is done with:
>> $ sudo gedit Â/etc/default/sl-modem-daemon
>> with the default therein being:
>>
>> SLMODEMD_COUNTRY=USA
>>
>> MarvS
>>
>> On Wed, Apr 6, 2011 at 8:13 AM, Antonio Olivares
>> <olivares14031@xxxxxxxxx> wrote:
>>> Mehdi,
>>>
>>> Have you tried with latest Ubuntu?
>>>
>>> If you do try it out, look for the packages sl-modem-src and
>>> sl-modem-daemon as suggested by Marv. ÂThis will take care of building
>>> the driver automagically if you install dkms beforehand.
>>>
>>> On Tue, Apr 5, 2011 at 9:02 PM, the mass <massreg@xxxxxxxxx> wrote:
>>>> Antonio,
>>>> I know that but since IRAN is not in the countries list, I left it to
>>>> let "slmodemd" use its default choice. I also used other countries but
>>>> made no difference.
>>> No problem. ÂI believed that is why you got the message about bad
>>> country string.
>>>>
>>>> And also in Ubuntu 8.04.1, it worked with YOUR_COUNTRY. but not in Ubuntu
>>>> 9.04.
>>> This is strange, but as long as you can connect it would be ok.
>>>
>>> Regards,
>>>
>>> Antonio
>>>>
>>>> On 4/6/11, Antonio Olivares <olivares14031@xxxxxxxxx> wrote:
>>>>> Mehdi,
>>>>>
>>>>> when dialing out you use YOUR_COUNTRY like USA, IRAN, and not specific
>>>>> "YOUR COUNTRY" as you get :
>>>>>
>>>>> bad country name `YOUR_COUNTRY', using default by code!
>>>>>
>>>>> Maybe that was the cause of the failure ?
>>>>>
>>>>> Regards,
>>>>>
>>>>> Antonio
>>>>>
>>>>> On Tue, Apr 5, 2011 at 8:36 PM, the mass <massreg@xxxxxxxxx> wrote:
>>>>>> I followed the insturctions but I couldn't connect to the internet in
>>>>>> Ubuntu 9.04 so I tryed the same procedure in Ubuntu 8.04.1,
>>>>>> surprisingly this time I successfully connected to the internet.
>>>>>>
>>>>>> I'm wondering what's wrong in the newer version.(the modem is
>>>>>> installed but doesn't dial)
>>>>>>
>>>>>>
>>>>>> Here's what I did:
>>>>>>
>>>>>> As you said I downloaded "SLMODEMD_gcc4.3_alsa1.0.18.tar.gz" and after
>>>>>> extraction I ran "sudo slmodemd -c YOUR_COUNTRY --alsa hw:0,6"
>>>>>> here's the result:
>>>>>>
>>>>>> ______________________________________________
>>>>>> SmartLink Soft Modem: version 2.9.11 Feb 25 2009 18:35:08
>>>>>> bad country name `YOUR_COUNTRY', using default by code!
>>>>>> symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
>>>>>> modem `hw:0,6' created. TTY is `/dev/pts/2'
>>>>>> Use `/dev/ttySL0' as modem device, Ctrl+C for termination.
>>>>>> _______
>>>>>>
>>>>>>
>>>>>> then I ran "sudo wvdialconf /etc/wvdial.conf"
>>>>>> and here's the file:
>>>>>>
>>>>>> wvdial.conf
>>>>>> ______________
>>>>>> [Dialer Defaults]
>>>>>> Init1 = ATZ
>>>>>> Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
>>>>>> Modem Type = Analog Modem
>>>>>> Baud = 460800
>>>>>> New PPPD = yes
>>>>>> Modem = /dev/ttySL0
>>>>>> ISDN = 0
>>>>>> Phone = 9092322424
>>>>>> Password = pass
>>>>>> Username = user
>>>>>> Carrier check = no
>>>>>> Stupid Mode = yes
>>>>>> #Dial Command = ATDP
>>>>>> ____
>>>>>>
>>>>>> After that I tryed to connect: "sudo wvdial"
>>>>>> and ...
>>>>>>
>>>>>> ________________________
>>>>>> --> WvDial: Internet dialer version 1.60
>>>>>> --> Cannot get information for serial port.
>>>>>> --> Initializing modem.
>>>>>> --> Sending: ATZ
>>>>>> ATZ
>>>>>> OK
>>>>>> --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
>>>>>> ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
>>>>>> OK
>>>>>> --> Modem initialized.
>>>>>> --> Sending: ATDT9092322424
>>>>>> --> Waiting for carrier.
>>>>>> ATDT9092322424
>>>>>> --> Timed out while dialing. ÂTrying again.
>>>>>> --> Sending: ATDT9092322424
>>>>>> --> Waiting for carrier.
>>>>>> --> Timed out while dialing. ÂTrying again.
>>>>>> ___________
>>>>>>
>>>>>>
>>>>>> Modem does not dial the number ( There is bing as it picks up the
>>>>>> telephone but there is no dialing).
>>>>>>
>>>>>> Best regards,
>>>>>> Mehdi
>>>>>>
>>>>>> _____________________________________________________________________
>>>>>> ____________________________________
>>>>>>
>>>>>> On 4/5/11, Marvin Stodolsky <marvin.stodolsky@xxxxxxxxx> wrote:
>>>>>>> Antonio,
>>>>>>> Â ÂI'll write the following instruction into scanModem shortly
>>>>>>>
>>>>>>> Mehdi
>>>>>>>
>>>>>>> RE: SLMODEMD_gcc4.3_alsa1.0.18.tar.gz
>>>>>>> Since you are using Ubuntu, it is better to use the Ubuntu package
>>>>>>> providing slmodemd
>>>>>>> ÂDownload the package sl-modem-daemon. ÂUnder Ubuntu it can be
>>>>>>> installed
>>>>>>> with:
>>>>>>> $ sudo dpkg -i sl*/deb
>>>>>>>
>>>>>>> Afterward the modem should be dectected by:
>>>>>>> $ sudo wvdialconf
>>>>>>>
>>>>>>> If successful use
>>>>>>> $ sudo gedit /etc/wvdial.conf
>>>>>>> to add a line:
>>>>>>> Carrier Check = no
>>>>>>> and edit in your personal information.
>>>>>>> Read the DOCs/Smartlink.txt for details.
>>>>>>>
>>>>>>> Please send further questions to the List, not me directly.
>>>>>>>
>>>>>>> MarvS
>>>>>>>
>>>>>>> On Tue, Apr 5, 2011 at 7:52 AM, Antonio Olivares
>>>>>>> <olivares14031@xxxxxxxxx> wrote:
>>>>>>>> Mehdi,
>>>>>>>>
>>>>>>>> scanModem reports that your modem is supported through SLMODEMD
>>>>>>>> package:
>>>>>>>>
>>>>>>>> Predictive Âdiagnostics for card in bus 00:14.2:
>>>>>>>> Â Â Â ÂModem chipset Âdetected on
>>>>>>>> NAME="Audio device: ATI Technologies Inc SBx00 Azalia "
>>>>>>>> CLASS=0403
>>>>>>>> PCIDEV=1002:4383
>>>>>>>> SUBSYS=1043:1339
>>>>>>>> IRQ=16
>>>>>>>> HDA2=00:14.2
>>>>>>>> SOFT=1002:4383.HDA
>>>>>>>> HDAchipVendorID=1057
>>>>>>>> CHIP=0x10573055
>>>>>>>> IDENT=slmodemd
>>>>>>>> SLMODEMD_DEVICE=hw:0,6
>>>>>>>> Driver=snd-hda-intel
>>>>>>>>
>>>>>>>> ÂFor candidate modem in: Â00:14.2
>>>>>>>> Â 0403 Audio device: ATI Technologies Inc SBx00 Azalia
>>>>>>>> Â Â ÂPrimary device ID: Â1002:4383
>>>>>>>> Â ÂSubsystem PCI_id Â1043:1339
>>>>>>>> Â ÂSoftmodem codec or chipset from diagnostics: 0x10573055
>>>>>>>>                from  ÂArchives:
>>>>>>>> Â Â Â Â Â Â Â Â Â Â Â ÂThe HDA card softmodem chip is 0x10573055
>>>>>>>>
>>>>>>>>
>>>>>>>> Support type needed or chipset: slmodemd supporting the snd-hda-intel
>>>>>>>> audio+modem driver
>>>>>>>>
>>>>>>>> ÂAn ALSA (Advanced Linux Sound Architecture) modem driver:
>>>>>>>> Âsnd-hda-intel
>>>>>>>> Âprovides Low Level support enabling contact with the modem hardware.
>>>>>>>> ÂFor all BUT Conexant chip soft modems (using hsfmodem software)
>>>>>>>> Âcomplementary High Level support is through a Smartlink utility:
>>>>>>>> Âslmodemd
>>>>>>>>
>>>>>>>> ÂDownload from http://linmodems.technion.ac.il/packages/smartlink/
>>>>>>>> Âthe package SLMODEMD_gcc4.3_alsa1.0.18.tar.gz having a compiled
>>>>>>>> slmodemd. Unpack under Linux with:
>>>>>>>> Â Â Â Â$ tar zxf SLMODEMD_gcc4.3_alsa1.0.18.tar.gz
>>>>>>>> Âand read instructions therein. But briefly, the modem is setup with
>>>>>>>> command:
>>>>>>>> Â Â Â Âsudo slmodemd -c YOUR_COUNTRY --alsa hw:0,6
>>>>>>>> Âreporting dynamic creation of ports:
>>>>>>>> Â Â Â Â/dev/ttySL0 --> /dev/pts/N Â , with N some number
>>>>>>>> ÂRead DOCs/Smartlink.txt and Modem/DOCs/YourSystem.txt for follow
>>>>>>>> through guidance.
>>>>>>>>
>>>>>>>>
>>>>>>>> Package that you need is here:
>>>>>>>>
>>>>>>>> http://linmodems.technion.ac.il/packages/smartlink/SLMODEMD_gcc4.3_alsa1.0.18.tar.gz
>>>>>>>>
>>>>>>>> Download it and follow instructions provided.
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>>
>>>>>>>> Antonio
>>>>>>>> On Tue, Apr 5, 2011 at 6:43 AM, the mass <massreg@xxxxxxxxx> wrote:
>>>>>>>>> Hi
>>>>>>>>> I have a ASUS F5RL laptop and I want to install its built-in modem
>>>>>>>>> in
>>>>>>>>> Ubuntu 9.04,
>>>>>>>>> but until now I wasn't able to install it.
>>>>>>>>>
>>>>>>>>> I have attached the ModemData.txt file.
>>>>>>>>>
>>>>>>>>> Thanks
>>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>



[Index of Archives]     [Linux DVB]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Fedora Women]     [Linux USB]

Powered by Linux