Google
  Web www.spinics.net

Rsvp with tc

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear mailing list,

I'm experiencing some troubles with the command tc and especially with the filter rsvp. I tried to use it like described in the help section  :

tc filter add dev eth0 parent 1:0 protocol ip priority 100 rsvp ipproto udp session 10.74.92.174/6000

after having created all the qdiscs described in cbqinit.eth0 (in the examples of tc/iproute2) :

$TC qdisc add dev $DEVICE root handle 1: cbq $BANDWIDTH allot 1514 $AVPKT mpu 64
$TC class add dev $DEVICE parent 1:0 classid :1 est 1sec 8sec cbq $BANDWIDTH rate 10Mbit allot 1514 maxburst 50 $AVPKT
$TC class add dev $DEVICE parent 1:1 classid :2 est 1sec 8sec cbq $BANDWIDTH rate 4Mbit allot 1514 cell 8 weight 500Kbit prio 6 maxburst 50 $AVPKT split 1:0 defmap ff3d
$TC qdisc add dev $DEVICE parent 1:2 sfq quantum 1514b perturb 15
$TC class add dev $DEVICE parent 1:1 classid :3 est 2sec 16sec cbq $BANDWIDTH rate 1Mbit allot 1514 weight 100Kbit prio 2 maxburst 100 $AVPKT split 1:0 defmap c0
$TC qdisc add dev $DEVICE parent 1:3 sfq quantum 1514b perturb 15
$TC class add dev $DEVICE parent 1:1 classid :4 est 1sec 8sec cbq $BANDWIDTH rate 100Kbit allot 1514 weight 10Mbit prio 7 maxburst 10 $AVPKT split 1:0 defmap 2
$TC qdisc add dev $DEVICE parent 1:4 sfq quantum 1514b perturb 15
$TC class add dev $DEVICE parent 1:1 classid 1:7FFE cbq rate 5Mbit $BANDWIDTH allot 1514b $AVPKT maxburst 20 cell 8
$TC class add dev $DEVICE parent 1:7FFE classid 1:7FFF  est 4sec 32sec cbq rate 1Mbit $BANDWIDTH allot 1514b $AVPKT weight 10Kbit prio 6 maxburst 10 split 1:7FFE defmap ffff

I've also tried a lot of variations (for exemple, I've tried to use the flowid option), but no one succeeded : the error is always the same :

RTNETLINK answers: Invalid argument
We have an error talking to the kernel.


I'm also using the daemon for RSVP written by ISI and patched by Alexey Kuznetsov, and I'm experiencing the same troubles when it comes to the filter option "rsvp", in the fonction tc_add_filter_proto of the file tc_filter.c. I've created the same qdiscs, but no filter.

I would like to know if any of you would have any clue. Does it need a particular kernel module ? I've already loaded all the sch* and cls* modules contained in kernel/net/sched (in particular, I've loaded cls_rsvp).

I'm using Debian 5. The version of the kernel is 2.6.26-2-686.

I thank you very much for your help.

Best regards,
Sébastien Henri.
#
" Ce courriel et les documents qui lui sont joints peuvent contenir des informations confidentielles ou ayant un caractère privé. S'ils ne vous sont pas destinés, nous vous signalons qu'il est strictement interdit de les divulguer, de les reproduire ou d'en utiliser de quelque manière que ce soit le contenu. Si ce message vous a été transmis par erreur, merci d'en informer l'expéditeur et de supprimer immédiatement de votre système informatique ce courriel ainsi que tous les documents qui y sont attachés."
******
" This e-mail and any attached documents may contain confidential or proprietary information. If you are not the intended recipient, you are notified that any dissemination, copying of this e-mail and any attachments thereto or use of their contents by any means whatsoever is strictly prohibited. If you have received this e-mail in error, please advise the sender immediately and delete this e-mail and all attached documents from your computer system."
#

_______________________________________________
LARTC mailing list
LARTC@xxxxxxxxxxxxxxx
http://mailman.ds9a.nl/cgi-bin/mailman/listinfo/lartc



[Bugtraq]     [Fedora Legacy]     [GCC Help]     [Yosemite News]     [Yosemite Photos]     [IP Tables]     [Netfilter Devel]     [Fedora Users]

Powered by Linux