[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

RE: need help -- "iSCSI session ioctl failed ... cannot allocate memory"



I am still in the installation phase.  I load the cisco driver using
driver-update-disk  as this is not available as boot time driver.  Yes I
have daemon statically compiled/linked on floppy.
Doing CTRL-ALT-F2  to go to the shell .  I tried to do modprobe crc32c &
md5  but I don't see those modules  when I type lsmod.  I can see the
iscsi_sfnet though.

Still getting the same error  in /tmp/syslog when I type #/sbin/iscsid,
daemon though gets the target name from discovery IP address .

What can I do next 

-----Original Message-----
From: Mike Christie [mailto:michaelc@xxxxxxxxxxx] 
Sent: Monday, October 17, 2005 4:15 AM
To: Aggarwal, VikasX
Cc: linux-iscsi-users@xxxxxxxxxxxxxxxxxxxxx
Subject: Re:  need help -- "iSCSI session ioctl
failed ... cannot allocate memory"

Aggarwal, VikasX wrote:

> 
>  
> 
> I am using 4.0.1.11  cisco iscsi initiator  and built it for
2.6.9-22EL  
> kernel using the kernel-develop package from RHEL4.0 U2  CDs
> 
>  
> 
> Do  I have to make sure that anaconda installer enabled these kernel 
> flags below. Not sure how to do that
> 
>      CONFIG_CRYPTO
> 
>      CONFIG_CRYPTO_MD5
> 
>      CONFIG_CRYPTO_CRC32C


     3. if CHAP is used MD5 support - md5
     4. if data or header digest are used - crc32c, libcrc32c

modprobe those modules. From the secret RHEL4 iscsi doc site 
http://people.redhat.com/mchristi/iscsi/RHEL4/doc/readme (this should be

in KB soon).


-------------------------------------------------------
This SF.Net email is sponsored by:
Power Architecture Resource Center: Free content, downloads, discussions,
and more. http://solutions.newsforge.com/ibmarch.tmpl
_______________________________________________
linux-iscsi-users mailing list
linux-iscsi-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/linux-iscsi-users


[IP Storage]     [IETF]     [Linux SCSI]     [iSCSI Book]     [Linux Resources]     [Yosemite News]     [Photo]     [Home]     [IETF Announcements]     [IETF Discussion]     [SCSI Hardware]