[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

FW: The problems for linux-iscsi on kernel 2.6



 

 

-----Original Message-----
From: blin [mailto:zllr@xxxxxxxxxxxx]
Sent: Friday, October 07, 2005 9:12 PM
To: linux-iscsi-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: The problems for linux-iscsi on kernel 2.6
Importance: High

 

Hello,

 

I am very confused for compiling linux-iscsi on kernel 2.6.

 

The fact on FC4 (2.6.11) was that the scsi_transport_iscsi.c file couldn’t be compiled. I used the original one located in /usr/src/redhat/BUILD/kernel-2.6.11/linux-2.6.11/driver/scsi to instead, and then it could be compiled. After that I installed the driver (make install) successfully and I got the initiatorname.iscsi and iscsi.conf files under /etc. I edited the iscsi.conf file (un-commented the line of TargetName and DiscoverAddress), and then started the iscsi daemon, but I didn’t find the target volume.

 

I also compiled the kernel 2.6.10 from kernel.org based on FC3 (2.6.9) and tried to install linux-iscsi, the scsi_transport_iscsi.c file (patched) could be compiled, but the iscsi-session.c file couldn’t. I tried the two methods for installation (part of kernel and external module), and the result was same.

 

I attached all the files that might be useful for help.

I really hope that you can help me for solving these issues. Thanks in advance!!

 

Best Regards,

Bill

 

 

Attachment: error_2.6.10
Description: Binary data

Attachment: error_fc4
Description: Binary data

Attachment: initiatorname.iscsi
Description: Binary data

Attachment: iscsi.conf
Description: Binary data


[IP Storage]     [IETF]     [Linux SCSI]     [iSCSI Book]     [Linux Resources]     [Yosemite News]     [Photo]     [Home]     [IETF Announcements]     [IETF Discussion]     [SCSI Hardware]