[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Remove 9 second reboot delay on Lenovo T400/T500



On Wed, Jul 14, 2010 at 03:33:08PM +0100, Pedro Ribeiro wrote:
>  Please consider this patch. Let me know if you would like me to change
>  anything or if you don't agree with it. It applies cleanly to 2.6.35-rc5.
> 
>  The Lenovo T400 and T500 have an annoying 9 second delay when
>  rebooting, unless reboot=pci is passed to the kernel command line.
>  This delay happens from at least kernel 2.6.20.
> 
>  Make this change permanent by hardcoding the Tx00 on the
>  arch/kernel/reboot.c pci quirks table.

There's two possibilities here:

1) Lenovo's firmware is broken and the 9-second delay is always going to 
be there. In that case we should try to use the ACPI reboot vector 
first.

2) We're doing something wrong in our shutdown sequence which then 
triggers this problem as a result.

Either way, I think this patch is wrong.

-- 
Matthew Garrett | mjg59@xxxxxxxxxxxxx

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
ibm-acpi-devel mailing list
ibm-acpi-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/ibm-acpi-devel


[Index of Archives]     [Linux ACPI]     [Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Photo]     [Yosemite Photos]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]


  Powered by Linux