PCIe Hotplugging not working

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I am trying to get PCIe endpoint hot - plugging working

The Set up is such that there is one endpoint (our custom device) connected to PCI  switch PLX 8609 8 port 8 lane switch. 
1. I have my driver module compiled, copied into /lib/modules/`uname -r`/kernel/drivers/char/
2. I run depmod and "modules.pcimap" also got updated with my module. 

However
 if I unplug and plug in the endpoint, my driver .probe and .remove functions
 are not being invoked. Is there something more to be done at the bus 
level to get the driver to hot plug ?

I have tried various kernel version, Currently I am trying on 2.6.38.12 (UBUNTU flavor).
First is there anything missing ? Also Please give me some pointers and debug direction.

Thanks
Anand

 		 	   		  --
To unsubscribe from this list: send the line "unsubscribe linux-hotplug" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux DVB]     [Video Technology]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Util Linux NG]     [Xfree86]     [Devices]     [Fedora Women]     [ALSA Devel]     [Linux USB]

Add to Google Powered by Linux