Need help with udev in CentOS 6.0 for SATA and eSATA HD

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I've recently installed CentOS 6.0 X86_64.

I have a server with two internal SATA hard disk drives running a software RAID 1. I'm adding two external eSATA hard disk drives which will be mirrored in a software RAID 1 too.

Please kindly correct me if this information is wrong, but I was told that the internal drives must be /dev/sda and /dev/sdb. And the eSATA should be /dev/sdc and /dev/sdd.

During my testing, I connected just one LaCie eSATA drive and it's getting assigned /dev/sdb while the internal drives are being assigned /dev/sda and /dev/sdc.

I want the internal drives to be sda and sdb. This external eSATA for testing to be /dev/sdc.

I've written some rules and placed them in /etc/udev/rules.d in a file named 10-local.rules:

KERNEL="sd*",ATTRS{model}=="LaCie d2Next-Q",NAME="sdc"

The above didn't work. I wondered if matching on KERNEL might be the problem. So I tried this:

ATTRS{model}=="LaCie d2Next-Q",NAME="sdc"

This didn't work either.

I've used udev successfully on CentOS 5 with USB drives to create SYMLINKs. But this is the first time I've tried to work with SATA drives where I want to force a renaming of the device. I don't think I should be trying to do a SYMLINK, because I simply want the device name itself changed.

By the way, I've also noticed that using udevadm it doesn't list the serial number of the drive like it did with udevinfo, unless I'm doing this wrong?
udevadm info -a -p $(udevadm info -q path -n /dev/sda)

Thanks in advance for your helpful suggestions!

David Roth

--
To unsubscribe from this list: send the line "unsubscribe linux-hotplug" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Linux DVB]     [Video Technology]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Util Linux NG]     [Xfree86]     [Devices]     [Fedora Women]     [ALSA Devel]     [Linux USB]

Add to Google Powered by Linux