[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: minimum software requirements..



On Wed, Nov 23, 2011 at 1:29 PM, Anthony Mayan <ifumust@xxxxxxxxx> wrote:
> i am very to knew to gtk+, we are developing using ubuntu but what are the
> minimum requirements?

Hi,
   I don't think you should consider the system that you are developing on
as the requirement for the application you are developing.

Instead, you should just consider what is the target system that your
application should run on once it's developed.

This means you might even want to develop using unreleased GTK+ from
git master if your target release date is reasonably later than say, 6 months
from now (in which case your app would be released shortly after the new
version of GTK+ is released... keeping you always on the bleeding edge
and ahead of the game...).

So in other words, just upgrade the system that you use to develop so that
that system has the GTK+ which you want to release with.

> Can we run an app created using gtk+ or gtkmm on ubuntu server without any
> gui installed?

GTK+ might fail to initialize on a system that has no X server running (or other
compliant backend that GTK+ might need for a GUI).

But you can develop gui-less apps using glib and libgio etc without
ever requiring
a GUI, of course.

Cheers,
          -Tristan

>
> Anthony
> _______________________________________________
> gtk-list mailing list
> gtk-list@xxxxxxxxx
> http://mail.gnome.org/mailman/listinfo/gtk-list
>
>
_______________________________________________
gtk-list mailing list
gtk-list@xxxxxxxxx
http://mail.gnome.org/mailman/listinfo/gtk-list


[GIMP Users]     [Yosemite News]    [Yosemite Photos]    [Gimp's Home]     [Steve's Art]

Add to Google Powered by Linux