Google
  Web www.spinics.net

Re: [problem] GNU Classpath build problems on Fedora 15

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 2011-09-27 at 15:31 +0300, Pekka Enberg wrote:
> I'm seeing this on Fedora 15:
> 
> [penberg@tux classpath.cvs]$ sh autogen.sh
> configure.ac:505: warning: AC_LIB_PREPARE_PREFIX is m4_require'd but
> not m4_defun'd
> m4/iconv.m4:11: AM_ICONV_LINKFLAGS_BODY is expanded from...
> m4/iconv.m4:22: AM_ICONV_LINK is expanded from...
> m4/iconv.m4:77: AM_ICONV is expanded from...
> configure.ac:505: the top level
> configure.ac:505: warning: AC_LIB_RPATH is m4_require'd but not m4_defun'd
> m4/iconv.m4:11: AM_ICONV_LINKFLAGS_BODY is expanded from...
> m4/iconv.m4:22: AM_ICONV_LINK is expanded from...
> m4/iconv.m4:77: AM_ICONV is expanded from...
> configure.ac:505: the top level

I don't have my F15 setup handy, but I think this is missing
iconv/gettext m4 macros. Try installing gettext-devel which should
provide /usr/share/aclocal/lib-prefix.m4

If that helps we should probably update the INSTALL and/or autogen.sh
checks.

Cheers,

Mark




[Linux Kernel]     [Linux Cryptography]     [Fedora]     [Fedora Directory]     [Red Hat Development]

  Powered by Linux