Google
  Web www.spinics.net

Re: Recently unable to install (really update) gnome3 on gentoo

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 21.08.2011 16:57, Allan Gottlieb wrote:
> I run gentoo and have been trying out gnome3 on one of my machines.
> A few days ago my normally daily system update (gentoo is source based)
> resulted in a failure I cannot understand.
>
>     oldlap ~ # emerge --newuse --update --with-bdeps=y --keep-going  --backtrack=30 world
>
>     These are the packages that would be merged, in reverse order:
>
>     Calculating dependencies... done!
>
>     emerge: there are no ebuilds to satisfy ">=net-im/telepathy-logger-0.2.4[introspection]".
>     (dependency required by "gnome-base/gnome-shell-3.0.2" [installed])
>     (dependency required by "gnome-base/gnome-light-3.0.0[shell]" [ebuild])
>     (dependency required by "@selected" [set])
>     (dependency required by "@world" [argument])
>
>     oldlap ~ # eix telepathy-logger
>     [I] net-im/telepathy-logger
>          Available versions:  0.1.7 (~)0.2.9 0.2.10 {doc +introspection test}
>          Installed versions:  0.2.10(11:00:55 AM 06/09/2011)(introspection -doc -test)
>          Homepage:            http://telepathy.freedesktop.org/wiki/Logger
>          Description:         Telepathy Logger is a session daemon that should be activated whenever telepathy is being used.
>
>     oldlap ~ # 
>
> The emerge fails saying it can't find an ebuild for telepathy-logger
> having version >= 0.2.4 and support for the introspection USE flag.
>
> But the eix command shows that, not only are there ebuilds with this
> property, but one such version is in fact installed.
This is a problem of emerge not recognizing  the version number
correctly. Compare the two: 0.2.10 >= 0.2.4 which is most likely
interpreted as 0.2.1 >= 0.2.4 and therefore false.
So you have to edit the ebuilds or file a bug for Gentoo.

_______________________________________________
gnome-list mailing list
gnome-list@xxxxxxxxx
http://mail.gnome.org/mailman/listinfo/gnome-list


[Home]     [Fedora Desktop]     [Kernel List]     [Red Hat Install]     [KDE]     [Red Hat Watch List]     [Red Hat Development]     [Red Hat 9 Bible]     [Red Hat 9 Mailing List]     [Big List of Linux Books]     [Gimp]     [Yosemite News]

Add to Google Powered by Linux