Google
  Web www.spinics.net

Re: Where have all my pictures gone?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Ulf-D. Ehlert skreiv:
> Kolbjørn Stuestøl (Mittwoch, 6. Mai 2009, 21:15):
> [...]
>   
>> There are no image references in the POT files although there are in
>> the src xml files.
>>     
>
> Ok, let's start with this problem:
>
> Does
> 	$  tools/xml2po src/introduction/whats-new.xml
> produce image references?
>   
In a way, but the image paths are not valid
Output: 
Warning: image file 
'src/introduction/images/using/empty-image-window.png' not found.
Warning: image file 
'src/introduction/images/using/scroll-beyond-border.png' not found.
...
The actual images are in the 'images/C/using' path so the 
'src/introduction/' part of the path should be omitted?

> Most likely it won't, but if it does, what about
> 	$  tools/xml2po src/introduction/whats-new.xml |
> 	> msguniq | msgcat --width=79 -
>   
The same warnings as above
> and
> 	$  touch -c src/introduction/whats-new.xml  # if necessary
> 	$  make -f Makefile.GNU pot/introduction.pot
>   
Images refs in the pot file unchanged:
#. When image changes, this message will be marked fuzzy or untranslated 
for you.
#. It doesn't matter what you translate it to: it's not used at all.
#: src/introduction/whats-new.xml:45(None)
msgid ""
"@@image: 'images/using/empty-image-window.png'; md5=THIS FILE DOESN'T 
EXIST"
msgstr ""


> If the first command does not produce image references, try
> 	$  grep 'submodes_path =' tools/xml2po
>   
Output:
submodes_path = "/usr/share/xml2po"
> This command should tell you where 'xml2po' expects to find its docbook 
> module (e.g. /usr/share/xml2po).
>
> Check if the module exists, e.g.
> 	$  ls /usr/share/xml2po/docbook.py
Output:
/usr/share/xml2po/docbook.py
> I'm pretty sure you won't find it there, so you'll have to find out 
> where this file is installed. I don't know how to do it with Cygwin,
> maybe
> 	$  locate docbook.py | grep xml2po
>   
No output, i.e. not found ;-)
I also tried 'locate -c docbook.py' and 'locate -c xml2po'. Both 
returned '0'.

> Then you can 
> 	a) create a link, e.g.
> 		$  ln -s /path/to/modules/of/xml2po /usr/share/xml/
>   
Command:
ln -s /usr/share/xml2po /usr/share/xml/
Output:
ln: creating symbolic link `/usr/share/xml/xml2po': File exists
> 	b) set a proper environment variable, e.g. (with bash):
> 		$  export PYTHONPATH=/path/to/modules/of/xml2po
>   
Command:
export PYTHONPATH=/usr/share/xml2po
No output (of cource)
>   
Running
touch -c src/introduction/whats-new.xml and then
make -f Makefile.GNU pot/introduction.pot gave the same result as before.
> Maybe you will have to change the above commands to make them work under 
> Cygwin, but I can't help you there (Linux-only user...).
>   
Is there any way to check out that a command is fulfilled with success?
Cygwin is *supposed* to emulate Linux and, as in Linux, the commands are 
sometimes a bit difficult to recognize. So I run lots of "info ..." 
commands searching for help on the commands, but I have to know what to 
search for ;-)
 
Tried:
touch -c src/introduction/whats-new.xml
make -f Makefile.GNU -d pot/introduction.pot >test-pot.txt
and got 27 MB of text, but not how the pot file is build. Are there any 
way to follow the making of the pot file(s) step by step/line by line?

Thank you a lot for your excellent help. You are a brilliant 
teacher/helper/tutor.
Have a nice week end
Kolbjoern
> Bye,
> Ulf
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> Gimp-docs mailing list
> Gimp-docs@xxxxxxxxxxxxxxxxxxxxxx
> https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-docs
>   


_______________________________________________
Gimp-docs mailing list
Gimp-docs@xxxxxxxxxxxxxxxxxxxxxx
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-docs


[Home]     [Video For Linux]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Yosemite Book Store]     [gtk]     [GIMP for Windows]     [KDE]     [Scanner]     [Memory]     [GEGL]     [Gimp's Home]     [Gimp on Windows]     [Steve's Art]     [Webcams]

  Powered by Linux