Google
  Web www.spinics.net

Re: make fails after git pull

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Tue, 2010-09-21 at 01:46 -0700, Patrick Horgan wrote:
> On 09/20/2010 10:18 PM, Danny Robson wrote:
> >
> > Can you confirm that config.h contains an appropriately generated
> > define for restrict? Perhaps you need to rerun autogen.sh to rebuild
> > configure?
> >    
> Well, running autogen.sh got me further, but I still have problems:
> 
> make[4]: Entering directory `/usr/local/geglbuild/docs/gallery'
> --[Updating sample compositions]--
> ../../../gegl/docs/gallery/clones.xml
> ** Message: Module '../../operations/external/.libs/ff-load.so' load 
> error: ../../operations/external/.libs/ff-load.so: undefined symbol: 
> avcodec_decode_video2
> 
> my libavcodec has an avcodec_decode_video, but no avcodec_decode_video2

The ffmpeg library is (in)famous for changing their APIs frequently and
releasing seldom. That's why pretty much every distribution ends up
using development snapshots, which are incompatible to each other.

Your best bet is to configure gegl with the --without-libavformat
option.


Sven


_______________________________________________
Gegl-developer mailing list
Gegl-developer@xxxxxxxxxxxxxxxxxxxxxx
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer


[Video For Linux]     [Photo]     [Yosemite News]    [Yosemite Photos]    [gtk]     [GIMP Users]     [KDE]     [Scanner]     [Gimp's Home]     [Gimp on Windows]     [Steve's Art]     [Webcams]