Re: gcc-4.2.4 compilation under ubuntu 11.10

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


11.5.2012 11:09, mikemodanoxxx kirjoitti:

I installed the missing libs now, but still i get the same error during
compilation. This is the last one i get:

/home/simon/Downloads/gcc-4.2.4/gcc/crtstuff.c:348: error: expected ‘{’ at
end of input

There are several other errors which all occur in the same file. An idea
anyone?

The row 348 in 'gcc-4.2.4/gcc/crtstuff.c' is :

CRT_CALL_STATIC_FUNCTION (INIT_SECTION_ASM_OP, frame_dummy)

So maybe the definition of macro INIT_SECTION_ASM_OP is faulty,
with simple words : Your gcc-4.2.4 sources are corrupted! How
this happened only you yourself could know :-(  Things like this
usually happen in the Windoze world, some unpacker replacing LFs
with CR-LF's and so on...

i tried to compile gcc-4.2.4 under ubuntu 11.10 because i need it for
matlab/mex. Here are my steps:

- Downloaded the source and extracted the zip in one folder
- Made another folder compile/ and changed to that folder.
- Called "sh /extractedFolder/configure --program-suffix=-4.2
--enable-languages=c,c++"
- Called "make bootstrap"

I tried quite the same on my Ubuntu 11.10 but using bare 'make'
which however seemed to default to 'make bootstrap'. No problems
anywhere, not even the missing 'gmp.h' you saw first :

After 10 minutes i received an error (see below) about the gmp.h.
>> Can somebody help me? Do I have to add other flags?

Your "need it for matlab/mex" could require elaboration... In my
experimental case "just for a fun", the build succeeded. So should
happen there after you check your sources not being corrupted via
a new download and unpack... Hmmm, I quite surely unpacked the
gcc-4.2.4 sources in the earlier Ubuntu 11.04 or in Fedora 14. But
if talking using the produced gcc-4.2.4 with something made for some
earlier Linux distros, one must know that the glibc against with the
new GCC 4.2.4 was produced, is much newer than the glibcs in those
gcc-4.2.4-age Linux distros. Whether this could cause problems is
hard to say, in any case the produced libstdc++-v3 etc C++ parts
were made to be in sync with the glibc-2.13 in Ubuntu 11.10, not
with some glibc-2.5 - glibc-2.7 releases in earlier Linuces...

My point is to tell that a gcc-4.2.4 made for something like
Fedora 8 isn't at all the same thing as a gcc-4.2.4 made for
Ubuntu 11.10 !  GCC isn't in any way "standalone" but dependent on
the binutils and the standard C library it uses as its companion
tools and components!



[Linux C Programming]     [Linux Kernel]     [eCos]     [Fedora Development]     [Fedora Announce]     [Autoconf]     [The DWARVES Debugging Tools]     [Yosemite Campsites]     [Yosemite News]     [Linux GCC]

Add to Google