Re: gcc-4.2.4 compilation under ubuntu 11.10

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I installed the missing libs now, but still i get the same error during
compilation. This is the last one i get:

/home/simon/Downloads/gcc-4.2.4/gcc/crtstuff.c:348: error: expected ‘{’ at
end of input

There are several other errors which all occur in the same file. An idea
anyone?



mikemodanoxxx wrote:
> 
> Hi there,
> 
> i tried to compile gcc-4.2.4 under ubuntu 11.10 because i need it for
> matlab/mex. Here are my steps:
> 
> - Downloaded the source and extracted the zip in one folder
> - Made another folder compile/ and changed to that folder.
> - Called "sh /extractedFolder/configure --program-suffix=-4.2
> --enable-languages=c,c++"
> - Called "make bootstrap"
> 
> After 10 minutes i received an error (see below) about the gmp.h. Can
> somebody help me? Do I have to add other flags? I just want to install
> gcc-4.2 in parallel to my normal gcc so that i can call the compiler with
> gcc-4.2. Is it even possible to install it that way or do i have to switch
> to another distribution of ubuntu?
> 
> Greets, mike.
> 
> config.log:
> 
> This file contains any messages produced by compilers while
> running configure, to aid debugging if configure makes a mistake.
> 
> configure:630: checking host system type
> configure:651: checking target system type
> configure:669: checking build system type
> configure:724: checking for a BSD compatible install
> configure:777: checking whether ln works
> configure:801: checking whether ln -s works
> configure:1866: checking for gcc
> configure:1979: checking whether the C compiler (gcc  ) works
> configure:1995: gcc -o conftest    conftest.c  1>&5
> configure:2021: checking whether the C compiler (gcc  ) is a
> cross-compiler
> configure:2026: checking whether we are using GNU C
> configure:2035: gcc -E conftest.c
> configure:2054: checking whether gcc accepts -g
> configure:2121: checking for gnatbind
> configure:2186: checking whether compiler driver understands Ada
> configure:2218: checking how to compare bootstrapped objects
> configure:2338: checking for correct version of gmp.h
> configure:2351: gcc -c -g -O2 -I/home/simon/Downloads/compile/gmp  
> conftest.c 1>&5
> configure:2341:17: fatal error: gmp.h: No such file or directory
> compilation terminated.
> configure: failed program was:
> #line 2340 "configure"
> #include "confdefs.h"
> #include "gmp.h"
> int main() {
> 
> #if __GNU_MP_VERSION < 4 || (__GNU_MP_VERSION == 4 &&
> __GNU_MP_VERSION_MINOR < 1)
> choke me
> #endif
> 
> ; return 0; }
> configure:3513: checking for bison
> configure:3513: checking for byacc
> configure:3513: checking for yacc
> configure:3553: checking for bison
> configure:3592: checking for gm4
> configure:3592: checking for gnum4
> configure:3592: checking for m4
> configure:3631: checking for flex
> configure:3631: checking for lex
> configure:3671: checking for flex
> configure:3710: checking for makeinfo
> configure:3763: checking for expect
> configure:3804: checking for runtest
> configure:3852: checking for i686-pc-linux-gnu-ar
> configure:3883: checking for ar
> configure:3927: checking for i686-pc-linux-gnu-as
> configure:3958: checking for as
> configure:4002: checking for i686-pc-linux-gnu-dlltool
> configure:4033: checking for dlltool
> configure:4077: checking for i686-pc-linux-gnu-ld
> configure:4108: checking for ld
> configure:4152: checking for i686-pc-linux-gnu-lipo
> configure:4183: checking for lipo
> configure:4227: checking for i686-pc-linux-gnu-nm
> configure:4258: checking for nm
> configure:4302: checking for i686-pc-linux-gnu-ranlib
> configure:4333: checking for ranlib
> configure:4372: checking for i686-pc-linux-gnu-strip
> configure:4403: checking for strip
> configure:4442: checking for i686-pc-linux-gnu-windres
> configure:4473: checking for windres
> configure:4517: checking for i686-pc-linux-gnu-objcopy
> configure:4548: checking for objcopy
> configure:4592: checking for i686-pc-linux-gnu-objdump
> configure:4623: checking for objdump
> configure:4704: checking for i686-pc-linux-gnu-cc
> configure:4735: checking for cc
> configure:4797: checking for i686-pc-linux-gnu-c++
> configure:4828: checking for c++
> configure:4890: checking for i686-pc-linux-gnu-gcc
> configure:4921: checking for gcc
> configure:4978: checking for i686-pc-linux-gnu-gcj
> configure:5009: checking for gcj
> configure:5071: checking for i686-pc-linux-gnu-gfortran
> configure:5102: checking for gfortran
> configure:5229: checking for ar
> configure:5283: checking for i686-pc-linux-gnu-ar
> configure:5314: checking for ar
> configure:5384: checking for as
> configure:5438: checking for i686-pc-linux-gnu-as
> configure:5469: checking for as
> configure:5539: checking for dlltool
> configure:5593: checking for i686-pc-linux-gnu-dlltool
> configure:5624: checking for dlltool
> configure:5694: checking for ld
> configure:5748: checking for i686-pc-linux-gnu-ld
> configure:5779: checking for ld
> configure:5849: checking for lipo
> configure:5903: checking for i686-pc-linux-gnu-lipo
> configure:5934: checking for lipo
> configure:6004: checking for nm
> configure:6058: checking for i686-pc-linux-gnu-nm
> configure:6089: checking for nm
> configure:6159: checking for objdump
> configure:6213: checking for i686-pc-linux-gnu-objdump
> configure:6244: checking for objdump
> configure:6314: checking for ranlib
> configure:6368: checking for i686-pc-linux-gnu-ranlib
> configure:6399: checking for ranlib
> configure:6469: checking for strip
> configure:6523: checking for i686-pc-linux-gnu-strip
> configure:6554: checking for strip
> configure:6624: checking for windres
> configure:6678: checking for i686-pc-linux-gnu-windres
> configure:6709: checking for windres
> configure:6759: checking where to find the target ar
> configure:6792: checking where to find the target as
> configure:6825: checking where to find the target cc
> configure:6858: checking where to find the target c++
> configure:6894: checking where to find the target c++ for libstdc++
> configure:6930: checking where to find the target dlltool
> configure:6963: checking where to find the target gcc
> configure:6996: checking where to find the target gcj
> configure:7032: checking where to find the target gfortran
> configure:7068: checking where to find the target ld
> configure:7101: checking where to find the target lipo
> configure:7124: checking where to find the target nm
> configure:7157: checking where to find the target objdump
> configure:7190: checking where to find the target ranlib
> configure:7223: checking where to find the target strip
> configure:7256: checking where to find the target windres
> configure:7317: checking whether to enable maintainer-specific portions of
> Makefiles
> configure:7366: checking whether -fkeep-inline-functions is supported
> configure:7381: gcc -c -g -O2 -fkeep-inline-functions  conftest.c 1>&5
> 

-- 
View this message in context: http://old.nabble.com/gcc-4.2.4-compilation-under-ubuntu-11.10-tp33763689p33770982.html
Sent from the gcc - Help mailing list archive at Nabble.com.




[Linux C Programming]     [Linux Kernel]     [eCos]     [Fedora Development]     [Fedora Announce]     [Autoconf]     [The DWARVES Debugging Tools]     [Yosemite Campsites]     [Yosemite News]     [Linux GCC]

Add to Google