Re: GCC 4.7.0 compiling problem Ubuntu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 10 April 2012 09:23, Kai Ruottu wrote:
> Knowing that eglibc for Ubuntu has those 'libc6-dbg_*.deb'
> install packages, one can only wonder what are they for and
> whether they would be required to be used with a debug-enabled
> 'libstdc++' ?
>
> That they are obligatory if one wants a debug -enabled libstdc++
> sounds quite obvious for me.

As someone who's never used Ubuntu it's not at all obvious to me.
What do those .deb files do and why are they needed to build libstdc++
with CXXFLAGS='-g3 -O0 -fno-inline' ?

> Are you sure that the 'libc6-dbg_*.deb'
> package(s) is/are installed?
>
>
>> With gcc 4.6.2 all works well.
>
>
> Maybe with gcc-4.6.2 accepts the usual non-debug eglibc to be
> linked with a debug-enabled libstdc++ ?

That's what I would expect.


[Linux C Programming]     [Linux Kernel]     [eCos]     [Fedora Development]     [Fedora Announce]     [Autoconf]     [The DWARVES Debugging Tools]     [Yosemite Campsites]     [Yosemite News]     [Linux GCC]

Add to Google