Re: Cross compiling for the 1750A

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


3.2.2012 15:14, ~Stack~ kirjoitti:

On 02/02/2012 04:07 AM, Andrew Haley wrote:
You might be in luck: in that zipfile is what may be a 1750 port of
binutils, which contains an assembler.  It's worth trying to build it
for a 1750A target.

http://downloads.cleanscape.net/1750a/resources/cpp1750.zip


Thanks again for your continued help.

I have managed to compile the binutils from that download. However I
still end up with the same error.

On the binutils, here is how I compiled it.
./configure --host=i386 --target=m1750-unknown-coff
--prefix=/opt/binutils-1750 --disable-nls --enable-languages=c
make all CC=gcc
sudo make install

Then I went to the gcc-3.1.1 and compiled it like this:
export PATH=/opt/binutils-1750:$PATH
./configure --prefix=/opt/gcc-3.1.1.1-1750a --target 1750a
--enable-obsolete --disable-nls --enable-languages=c
make all-gcc

As you can see the $target names, "m1750-coff" and "1750a", are not
the same :-( So, are they the same target?

I tried this too and the result was that the assembler made for the
'm1750-coff' target from the GNU binutils-2.7 didn't "grok" the output
from gcc-3.1.1, there assuming "m1750 == 1750a", ie symlinking the
1750a stuff to appear as identical m1750 stuff in 'gcc/config/m1750'.

The "as1750" should understand the output from a '1750a' targeted
plain vanilla FSF GCC...

The 'm1750-coff' targeted GNU binutils-2.7 then should work with the
output from the gcc-2.7.2 for 'm1750-coff'...

Yet I was unable to progress any further.

My colleague reached out to that email you found and got an answer. Mr
Kellogg provided us with the link:

http://okellogg.de/x.html

He has an assembler there for us to use. We were able to get the
simulator compiled quickly, but we are still working on the assembler.

This is the right route I think, if you are going to use the '1750a'
port in gcc-3.* !

How the 'm1750-coff' port differs from the '1750a' port has not been
looked by me, the config files like the '.md' one have different sizes
in the (patched) gcc-2.7.2. In any case the 'm1750-coff' port could be
an alternative route. Seemingly it supports the '1750b' model (what are
the differences?) too. But then gcc-2.7.2 would be the first GCC before
trying to move the port to newer GCC-versions...

I am probably doing something wrong. How do I tell the new gcc build to
look at the new linker/binutils?

Just try '1750a-gcc -print-search-dirs' and see where it expects the
'as' being (in '$prefix/$target/bin' of course!). So just copy it and
other binutils there. And then see what it complains :-) (All the
assembler directives were not understood in the 'm1750-coff' assembler)




[Linux C Programming]     [Linux Kernel]     [eCos]     [Fedora Development]     [Fedora Announce]     [Autoconf]     [The DWARVES Debugging Tools]     [Yosemite Campsites]     [Yosemite News]     [Linux GCC]

Add to Google