[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

[ gaim-Support Requests-1409165 ] how to use the new perl api? (it works?)



Support Requests item #1409165, was opened at 2006-01-18 11:08
Message generated for change (Comment added) made by deryni9
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=200235&aid=1409165&group_id=235

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
>Status: Pending
Priority: 5
Private: No
Submitted By: Stefan Pantiru (spantiru)
Assigned to: Etan Reisner (deryni9)
Summary: how to use the new perl api? (it works?)

Initial Comment:
I installed 2.0.0beta1 and also two different versions
from CVS and none of 
them wouldn't use the new perl api.

Actually I need Gaim::Accounts::get_all_active() and 
Gaim::Account::set_status() functions. But it seems I
can't use those even 
with the latest CVS version. 
The old Gaim::accounts() works though. How come the old
api works?

Running in debug mode, somewhere, it says something
like this:

plugins: probing /home/spantiru/local/lib/gaim/gaimrc.so
plugins: probing
/home/spantiru/local/lib/gaim/libgaimperl.so
plugins: /home/spantiru/local/lib/gaim/libgaimperl.so
is not usable because 
the 'gaim_init_plugin' symbol could not be found.  Does
the plugin call the 
GAIM_INIT_PLUGIN() macro?
plugins: probing /home/spantiru/local/lib/gaim/tcl.so
plugins: probing /home/spantiru/local/lib/gaim/ssl.so


This looks ok though:

plugins: probing /home/spantiru/local/lib/gaim/idle.so
plugins: probing /home/spantiru/local/lib/gaim/perl.so
plugins: probing /home/spantiru/local/lib/gaim/libgg.so


In my script, I use

perl_api_version => 2


(Not sure how useful this info is...)

Thanks for your time!

----------------------------------------------------------------------

>Comment By: Etan Reisner (deryni9)
Date: 2006-11-01 22:00

Message:
Logged In: YES 
user_id=516184

Are you still having this problem? Did you leave a package
managed version of gaim (1.5.0?) installed on your system
when you were trying the 2.0.0 beta version of gaim?

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=200235&aid=1409165&group_id=235

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Gaim-support mailing list
Gaim-support@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/gaim-support

[Home]     [Kernel List]     [Red Hat Install]     [Red Hat Watch List]     [Red Hat Development]     [Red Hat 9 Bible]     [Red Hat 9 Mailing List]     [Gimp]     [Yosemite News]

Powered by Linux