[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

[ gaim-Support Requests-1462515 ] When cygwin1.dll files are deleted Gaim stops working



Support Requests item #1462515, was opened at 2006-03-31 21:36
Message generated for change (Settings changed) made by newkirkj
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=200235&aid=1462515&group_id=235

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: win32
Group: None
Status: Open
Priority: 5
Submitted By: Jarrod Newkirk (newkirkj)
>Assigned to: Nobody/Anonymous (nobody)
Summary: When cygwin1.dll files are deleted Gaim stops working

Initial Comment:
For a programming class at college we are using cygwin.
We are using Cygwin on Windows to compile the files
with the "make" command that will be used to run a
microprocessor.  I went to compile the files with
"make" and an error came up that said there was more
than one "cygwin1.dll" file on the computer.  The error
then said to search for the other cygwin1.dll files and
then delete the older files and leave the newest
"cygwin1.dll" file.  I did this and the make worked and
compiled the files perfectly on Cygwin.  That I tried
to run gaim and it would not come up.  I then restored
the deleted files with no effect.

So I then uninstalled gaim and reinstalled it.  This
did not fix the problem.

This has occurred to me on two different computers. 
When the other two cygwin1.dll files are deleted gaim
will not work or even come up.  Any of us that are
using cygwin have to delete the other cygwin1.dll files
off our computers for the Linux "make" command to work.
 When we do this gaim stops working and cannot be fixed.

I was wondering if anyone has come across this problem
before.

I use gaim all the time and would hate to have to stop
using it because of Cygwin.

Jarrod Newkirk
jnewkirk@xxxxxxxxxxxx



----------------------------------------------------------------------

Comment By: Jarrod Newkirk (newkirkj)
Date: 2006-04-02 00:07

Message:
Logged In: YES 
user_id=1460221

I looked at the path and cygwin was not in the path but
GNUARM was, which uses the cygwin1.dll.  This is the program
being used by Cygwin to cross platform the program.  It
compiles the programs in Windows for the ARM Tini2131
microprocessor.  If I remove it from the path, the make
command in cygwin will not work, but gaim will load fine.  I
put the path back in, and gaim will load sometimes with a
error at the opening. 

The error is "This application has failed to start because
cygwin1.dll was not found.  Re-installing the application
may fix this problem."  After I click OK gaim loads.

I remember in the setup of the GNUARM program, it sets the
path variable to its bin directory so cygwin can use it
programs.

Do you have any other suggestions?

----------------------------------------------------------------------

Comment By: Daniel Atallah (datallah)
Date: 2006-04-01 01:58

Message:
Logged In: YES 
user_id=325843

I read this three times and it still doesn't make sense. 
Gaim itself doesn't use cygwin at all.

The problem is that you have cygwin in your System PATH. 
I'm guessing that by removing the dll you mention, you cause
the other instance of cygwin (that is in your path) to not
be broken... which in turn causes gaim's tcl loader plugin
to error and gaim not to start (this particular problem is
described in the wingaim FAQ).

It is bad practice to introduce incompatible dlls into your
System PATH - and putting cygwin in it does just that.

You should remove cygwin from the PATH and gaim will work
just fine.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=200235&aid=1462515&group_id=235


-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642
_______________________________________________
Gaim-support mailing list
Gaim-support@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/gaim-support

[Home]     [Kernel List]     [Red Hat Install]     [Red Hat Watch List]     [Red Hat Development]     [Red Hat 9 Bible]     [Red Hat 9 Mailing List]     [Gimp]     [Yosemite News]

Powered by Linux