[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Problems installing 2.6.0 on Vista



I am trying to build FC 2.6.0 using MinGW on a Vista machine.

 

The “configure” and “make” commands run perfectly but when I run “make install” it crashes at this point:

 

C:/Windows/fonts: caching, new cache contents: 1159 fonts, 0 dirs

C:/Users/Qu0ll/AppData/Local/Temp/fontconfig/cache: cleaning cache directory

D:\MSYS\1.0\local\bin\fc-cache.exe: failed

C:/Windows/fonts: failed to write cache

make[2]: *** [install-data-local] Error 1

make[2]: Leaving directory `/home/Qu0ll/fontconfig-2.6.0'

make[1]: *** [install-am] Error 2

make[1]: Leaving directory `/home/Qu0ll/fontconfig-2.6.0'

make: *** [install-recursive] Error 1

 

I first thought this might have something to do with Vista UAC but disabling that hasn’t helped.  It appears that it’s trying to write to a folder on the C: drive and failing.  Perhaps it needs admin privileges though I thought it would inherit those of the Windows user which is an administrator.

 

Anyway, when I run the test program it fails the basic check.  When I run fc-list on its own it says it can’t find the default configuration file.

 

How can I resolve these issues?

 

Thanks,

 

-JCT

_______________________________________________
Fontconfig mailing list
Fontconfig@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/fontconfig

[Fedora Users]     [Fedora Cloud]     [Kernel]     [Fedora Legacy]     [Fedora Packaging]     [Fedora Desktop]     [PAM]     [Red Hat Development]     [Red Hat 9]     [Gimp]     [Yosemite News]

  Powered by Linux