Google
  Web www.spinics.net

Re: Reminder: Fedora 17 virt test day going on right now!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Fri, May 04, 2012 at 09:36:49AM -0400, Gordon McLellan wrote:
> On Fri, May 4, 2012 at 4:23 AM, Dario Faggioli <raistlin@xxxxxxxx> wrote:
> 
> > On Thu, 2012-05-03 at 11:04 -0400, Gordon McLellan wrote:
> > > Greetings,
> > >
> > Hi,
> >
> > > Is anyone running FC 17 beta as a Dom0 / DomU on Xen 4, on Sandy
> > > Bridge hardware?
> > >
> > Not yet... I'm planning to do so ASAP.
> >
> > > I've been trying and trying to get xen going on my new sandy-e system
> > > and have gotten the hypervisor to load but the dom0 kernel panics
> > > during boot.
> > >
> > >
> > > I dug up an old copy of FC 15, will try my luck there next.
> > >
> > Never tried FC15 either, but just installing the xen packages in FC16
> > brought up a working virtualization environment every time I tried. I'll
> > give it a go again (no, I  don't have them installed right now) and let
> > you know if that still works for me.
> >
> > Regards,
> > Dario
> 
> 
> 
> Dario,
> 
> Yes, 16 is what I meant to type (oops).  I did a minimal install, and
> without updating, did a yum install xen, tweaked around with grub.cfg and
> the network-scripts a little and boom hypervisor and dom0 up and running,
> with VT-d support.
> 
> Tried the same thing with 17 again and could not get the dom0 kernel to
> boot successfully.

This sounds like a new machine, so I wonder if you are hitting this
xsave issue. You might try 'xsave=0' on the Xen hypervisor line.

> 
> I'm going to buy a serial card for this machine so I can do the serial
> console on Xen and get more information. But so far, so good!

You can try to do (on Xen) 'console=vga  vga=text-80x50 guest_loglvl=all loglvl=all noreboot"
and on the Linux command line: "console=hvc0 earlyprintk=xen loglevel=8 debug radeon.modeset=0 radeon.modeset=0"

That should give you some idea where it is crashing and take a photo.

Also, we did have this issue: https://lkml.org/lkml/2012/4/3/178

which should be fixed in the latest v3.x kernel from Fedora. So it might
be that you need to update the kernel (yum update) if that is what you see.

> 
> Gordon

> --
> xen mailing list
> xen@xxxxxxxxxxxxxxxxxxxxxxx
> https://admin.fedoraproject.org/mailman/listinfo/xen

--
xen mailing list
xen@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/xen



[Fedora Legacy Announce]     [Fedora Music]     [Fedora Extras]     [Linux Kernel]     [Fedora Legacy]     [Fedora Desktop]     [Fedora Directory]     [PAM]     [Red Hat Development]     [Red Hat 9]     [Big List of Linux Books]     [Gimp]     [Yosemite News]     [Yosemite Camping]

Powered by Linux