Google
  Web www.spinics.net

Re: [Xen-devel] Xen4.1.0 and Fedora15 Block device bug?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Wed, Jul 06, 2011 at 09:32:50AM -0400, Konrad Rzeszutek Wilk wrote:
> > > > https://bugzilla.redhat.com/show_bug.cgi?id=718382
> > >
> > > Anybody have some patches for it? They can be posted on the dracut mailing
> > list?
> > > Did loading those two modules in the install initrd fix the installation?
> > 
> > The aforementioned 'xen_emul_unplug=never' kernel arg has worked well enough
> > for me. I've pasted it into my kickstart files and my vms have been
> > installing and running fine.
> 
> Ok, but with HVM drivers instead of the PV - at least during installation.
> Is the 'xen_emul_unplug=never' option also present in your VM when it is running?

So I didn't even attempt to install it under HVM. I put this in my config file:

kernel = "/mnt/tftpboot/f15-x86_64/images/pxeboot/vmlinuz"
ramdisk="//mnt/tftpboot/f15-x86_64/images/pxeboot/initrd.img"
extra="console=hvc0 debug earlyprintk=xenboot askmethod vnc"
memory = 1024
name = "Fedora"
vcpus=2
vif = [ 'mac=00:0F:4B:00:00:63,bridge=switch' ]
disk = [ 'phy:/dev/vg_guest_1/FC15,xvda,w' ]
boot = "dnc"
vnc=1
videoram=8
vnclisten="0.0.0.0"
vncpasswd=''
stdvga=0
serial='pty'

And was able to install it.
--
xen mailing list
xen@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/xen


[Fedora Legacy Announce]     [Fedora Music]     [Fedora Extras]     [Linux Kernel]     [Fedora Legacy]     [Fedora Desktop]     [Fedora Directory]     [PAM]     [Red Hat Development]     [Red Hat 9]     [Big List of Linux Books]     [Gimp]     [Yosemite News]     [Yosemite Camping]

Powered by Linux