[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: [Fedora-tools-list] backward compatibility issue



On Wed, Mar 09, 2005 at 01:35:10PM -0700, Lonnie Gliem wrote:
> I have been trying to get VCS to run with Fedora Core 3. Since VCS was
> supporting enterprise 3.0. I took the compat-gcc and compat-glibc source
> rpms from enterprise 4.0 and built them with the fedora libs. That
> worked so I then installed them which also worked. I then added -
> L /usr/lib/i386-redhat-linux3E/lib to the link line for VCS. 
> But I still get the same link error as without the compat libs. See
> Below. Anyone know what I have done wrong??

It is not enough that you have compat-glibc installed, you need
to actually use it.
I.e. instead of using gcc use
gcc -static-libgcc -I /usr/lib/i386-redhat-linux7/include \
  -B /usr/lib/i386-redhat-linux7/lib/ -L /usr/lib/i386-redhat-linux7/lib/

	Jakub


[GCC Help]     [Fedora Development]     [Fedora Announce]     [Fedora Legacy Announce]     [Home]     [Fedora Config]     [PAM]     [Red Hat 9 Bible]     [Red Hat 9]     [Big List of Linux Books]     [Gimp]     [Yosemite News]

Powered by Linux