[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strange semodule_expand error during linking



> My bet is that it is related to how you apply your patches.
This can't be the cause in itself. When I build exactly the same policy, 
but "activated" these modules (i.e. instead of "off" place " module" 
instead - i.e. no real change made) everything passes with no errors.

This is also how I used to build my previous versions of the same policy 
(FC13) - no problems there either.

>  Also i
> would, like i said before, just remove any reference to modules that you
> do not want installed from modules-targeted.conf.
>   
It makes no difference - I already tried that.

> The Error message does not ring any bells for me either.
>   
Ah, well. I'll dig in to see if I can find what is causing this.

I suspect it may be something to do with the user role "modules" I 
switched off - dbadm, webadm, staff, unprivuser, guest and xguest. 
Although I do not need any of these (and neither do any of the modules I 
compiled - as far as I know), there are quite a few other *-targeted.* 
files in the source directory I haven't looked at. There might be 
something in them, which causes this, so I'll probably check that.

This is the only potential reason for this error. I am speculating here, 
because I truly don't know what on Earth does "invalid module in module 
package (at section 0)" mean? Do you get the same error when you try to 
build the policy with "rpmbuild -bb" after applying my patches?

--
selinux mailing list
selinux@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/selinux


[Fedora Users]     [Fedora Legacy]     [Fedora Desktop]     [Big List of Linux Books]     [Yosemite Photos]     [Yosemite News]     [Yosemite Campsites]     [KDE Users]     [Gnome Users]

Powered by Linux

Google
  Web www.spinics.net