Google
  Web www.spinics.net

Re: error: Package already exists: %package debuginfo

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


ok removed the macro from .rpmmacros

i think the error was because i had comment
#This ...
in the %install section

since i did NOT have any
%package debuginfo

hence i deduce that
So i am back to reading up on Rules and regulations on what is allowed and recommended practices but not sure
where i can find detailed information
i am reading Maximum RPM and looking at
http://stereochro.me/ideas/rpm-for-the-unwilling


From: Michael Schwendt <mschwendt@xxxxxxxxx>
To: packaging@xxxxxxxxxxxxxxxxxxxxxxx
Sent: Friday, April 13, 2012 5:06 PM
Subject: Re: error: Package already exists: %package debuginfo

On Fri, 13 Apr 2012 13:54:54 -0700 (PDT), KA (Kamal) wrote:

> Found a solution
>
> echo "%debug_package %{nil}" >> ~/.rpmmacros

Not good. That disables the automatic -debuginfo package builds.
The better "fix" for your problem would be to drop the
  %package debuginfo
from your spec file, because you are not supposed to handle the
debuginfo files yourself. You haven't told why you added such
a %package definition to your spec file.
--
packaging mailing list
packaging@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/packaging

--
packaging mailing list
packaging@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/packaging

[Home]     [Fedora Legacy]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net