Google
  Web www.spinics.net

Re: Fwd: Fwd: Broken dependencies: gstreamer-java

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 15:04:52 Friday 14 October 2011 Farkas Levente wrote:
> anybody can help in this?

You seem to have outdated yum info.
[akurtakov@rh eclipse.platform.swt]$ repoquery --disablerepo=\* --
enablerepo=rawhide --whatprovides libswt3-gtk2
[akurtakov@rh eclipse.platform.swt]$ 
i.e. nothing provides it.

Anyway, gtk2 is implementation detail for swt and we started to work on 
getting it working with gtk3. As a first step I dropped the old gtk2 virtual 
provides which are long time not needed .
Sorry for the inconvinience - I have changed the BR/R in gstreamer-java and 
committed but I can't rebuild due to buildroots being broken now. Simple 
rebuilding once things are normal should work fine.

Alex

> thanks
> 
> -------- Original Message --------
> Subject: Fwd: Broken dependencies: gstreamer-java
> Date: Mon, 10 Oct 2011 15:35:49 +0200
> From: Farkas Levente <lfarkas@xxxxxxxxxxx>
> To: Discussion of Fedora build system <buildsys@xxxxxxxxxxxxxxxxxxxxxxx>
> 
> hi,
> can anybody tell meg why i get these mails for all fedora release?
> imho on all fedora version eclipse-swt provides libswt3-gtk2 (and even
> you think so):
> ---------------------------
> yum --disablerepo=\* --enablerepo=fedora-rawhide provides libswt3-gtk2
> Loaded plugins: aliases, downloadonly, list-data,
> post-transaction-actions, priorities, refresh-packagekit, versionlock
> 1:eclipse-swt-3.7.0-1.3.fc16.x86_64 : SWT Library for GTK+-2.0
> Repo        : fedora-rawhide
> Matched from:
> Other       : libswt3-gtk2
> ---------------------------
> so what can be the problem???
> thanks.
> 
> 
> -------- Original Message --------
> Subject: Broken dependencies: gstreamer-java
> Date: Mon, 10 Oct 2011 13:20:08 +0000 (UTC)
> From: buildsys@xxxxxxxxxxxxxxxxx
> To: gstreamer-java-owner@xxxxxxxxxxxxxxxxx
> 
> 
> 
> gstreamer-java has broken dependencies in the rawhide tree:
> On x86_64:
> 	gstreamer-java-swt-1.5-1.fc16.x86_64 requires libswt3-gtk2
> On i386:
> 	gstreamer-java-swt-1.5-1.fc16.i686 requires libswt3-gtk2
> Please resolve this as soon as possible.
> 
> 
> --
> packaging mailing list
> packaging@xxxxxxxxxxxxxxxxxxxxxxx
> https://admin.fedoraproject.org/mailman/listinfo/packaging
--
packaging mailing list
packaging@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/packaging


[Home]     [Fedora Legacy]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net