[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

[Bug 810676] Review Request: aws - Ada Web Server (Web framework for Ada)



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.


https://bugzilla.redhat.com/show_bug.cgi?id=810676

Björn Persson <bjorn@xxxxxxxxxxxxxxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|                            |needinfo?(pavel@xxxxxxxxxxx
                   |                            |)

--- Comment #6 from Björn Persson <bjorn@xxxxxxxxxxxxxxxxxxxx> 2012-04-15 18:48:04 EDT ---
There are several files in the directory "include" that look like bundled
libraries. Zlib is a clear case and easy to handle: The directory include/zlib
must be deleted during the prep stage. It's not so obvious what should be done
about the other files in the include directory. Are they distributed separately
at other websites, or has Adacore taken over maintenance and become the
canonical source of those files? Should they be considered "copylibs"? Have you
investigated this? I can't even find a license statement for the sha* files.

I see that your build system divides the code into shared libraries quite
differently from the upstream. Adacore's build system produced three libraries
called "libaws.so", "libaws_ssl.so" and "libaws_include.so" when I tried it.
Yours produces "libaws.so.2.10.0" and "libtemplates_parser.so.2.10.0". Could
you explain the reasoning behind this? Do you think separate aws_ssl and
aws_include libraries aren't useful, and if so why? Conversely, do you think a
separate templates_parser library is useful, and why? Your choice may well be
the better one but I'd like to see your reasons. Perhaps you should install a
README.Fedora where you explain your reasoning?

I'm afraid you can't link to OpenSSL, as the OpenSSL license is incompatible
with the GPL. I see that there is an option to link to GnuTLS instead. Please
use that if possible.

Have you tried enabling IPv6? APNIC ran out of IPv4 address blocks one year
ago, and RIPE NCC is expected to run out within a year. There are no valid
excuses for not supporting IPv6 in 2012.

Shouldn't awsres and wsdl2aws be packaged? In a subpackage called "aws-tools"
perhaps? And maybe aws_password and webxref could be built and installed too?

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
_______________________________________________
package-review mailing list
package-review@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/package-review



[Fedora Legacy]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Add to Google