Re: usrmove breaks on directory name conflict

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

On Mon, 2012-04-23 at 09:45 -0600, Daniel Drake wrote: 
> Hi,
> 
> Last week I tried a preupgrade from F16 to F17 beta.
> 
> When rebooting into the preupgrade environment, the upgrade failed in usrmove:
> 
> Make a copy of /mnt/sysimage/usr/bin
> Merge the copy with /mnt/sysimage/bin
> cp: cannot overwrite directory /mnt/sysimage/usr/bin.usrmove-new/mkdir
> with non-directory
> Something failed. Move back to the original state.
> 
> 
> Rebooted back into F16. It looks like the issue was that I had a
> directory at "/usr/bin/mkdir/". No idea how, looks like it was from
> December. Probably my fault, but perhaps usrmove shouldn't fall over
> when facing this situation.
> 
> After removing that weird directory, I rebooted into preupgrade and it
> worked fine. Now running F17 beta.

you should open a bug report in rhbz , with component preupgrade .  

Tks, 
-- 
Sérgio M. B.

-- 
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/devel



[Fedora Announce]     [Fedora Kernel]     [Fedora Testing]     [Fedora Legacy Announce]     [Home]     [Fedora Tools]     [Fedora PHP Devel]     [Kernel List]     [Fedora Legacy]     [Fedora Maintainers]     [Fedora Maintainers]     [Fedora Desktop]     [PAM]     [Red Hat Development]     [Big List of Linux Books]     [Gimp]     [Yosemite News]

Add to Google Powered by Linux