Re: ecryptfs doesn´t like noauto and noatime

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Am Dienstag, 17. Januar 2012 schrieb Jakob Unterwurzacher:
> On 16.01.2012 10:44, Martin Steigerwald wrote:
> > Hi!
> > 
> > I have
> > 
> > merkaba:~> grep ecrypt /etc/fstab
> > /home/.ms               /home/ms                ecryptfs
> > noatime,noauto  0       0
> > 
> > And get:
> > 
> > merkaba:~> mount /home/ms
> > Passphrase:
[…]
> > Error mounting eCryptfs: [-5] Input/output error
[…]
> > Still it works.
> > 
> > 
> > In dmesg I see:
> > 
> > [ 2657.888355] ecryptfs_parse_options: eCryptfs: unrecognized option
> > [noauto]
> > [ 2657.888359] ecryptfs_parse_options: eCryptfs: unrecognized option
> > [noatime]
> > [ 2657.913215] alg: No test for __gcm-aes-aesni
> > (__driver-gcm-aes-aesni)
> > 
> > 
> > Thus I removed at least noatime, but then I still see:
> > 
> > [ 2839.460200] ecryptfs_parse_options: eCryptfs: unrecognized option
> > [noauto]
[…]
> > Without noatime it would ask me the passwort upon boot, but I do not
> > like that since I do not use that user everytime.

noauto that is.

> > I could use mounting via pam, but I like to have a different password
> > for the user stored in /etc/shadow than the password from the
> > filesystem itself.
> 
> Note that this should work by creating ~/.ecryptfs/wrapping-independent
> . Pam will ask for the ecryptfs password explicetely then.

Thanks.

Would that also work within a display manager like kdm?

Ciao,
-- 
Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7
--
To unsubscribe from this list: send the line "unsubscribe ecryptfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[LARTC]     [Bugtraq]     [Yosemite Forum]     [Photo]

Powered by Linux