Re: Redboot for FSL TWRK70F120M with Linux kernel booting

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




On 15.03.2012 18:01, Linh Nguyễn wrote:
> Hi Ilija & all,
>
> On Thu, Mar 15, 2012 at 10:56 PM, Ilija Kocho <ilijak@xxxxxxxxxxx> wrote:
>> Hi Linh
>>
>> Thank you for the files. Now it works (I had errors in MCG structure).
>>
>> On 15.03.2012 05:04, Linh Nguyễn wrote:
>>> On Wed, Mar 14, 2012 at 4:27 PM, Ilija Kocho <ilijak@xxxxxxxxxxx> wrote:
>>>> I think you don't need to add dram region but simply declare dram as
>>>> main ram.
>>>> I think it will be easiest for you if you use TWR-K60N512-FXM target as
>>>> example. (added recently so you may need to update/checkout eCos). It is
>>>> very similar to what you probably need - only with FlexBus external
>>>> memory instead of DDR. Probably in addition to initialization code you
>>>> only need to change base address and size of RAM and it should work.
>>>>
>>>> I hope this helps. Looking forward to your feedback.
>>> Hi Ilija and all,
>>> I have replace DRAM as main RAM as your K60 fxm and it is OK
>>> currently. But I have another problem about ether net :).
>>> With the same situation, when I use internal RAM the ethernet can get
>>> BOOTP with DHCP ip immediately with booting, but when I use DRAM as
>>> main RAM the board can't get BOOTP information, it said "networking is
>>> not available". Do you know where is the reason? Thanks so much.
>> On my Tower RedBoot works with Ethernet and DDR that would exclude
>> hardware incompatibility. I would suggest you to try if you have
>> forgotten to add Common Ethernet Support.
>>
>> If yes, then please describe your current software configuration of eCos
>> and FS modules.
>>
> In my situation, Common Ethernet Support added, and ethernet work well
> when I use internal ram as main ram. But when I use external dram as
> main ram, ethernet does not work :).
>
> Although my eCos work with K70 but it does not work with other boards

So Ethernet works with DDRAM with eCos but not with RedBoot?

> & many hard-code for K70 only :). On the other hand, my main purpose
> when using Redboot for K70 is booting Linux kernel for it.

Have you tried the Linux on K70?

> So if you
> have done Redboot for K70 and it works well, please share it soon ^^!
> I think it better than mine.

I would like it to happen asap but I'm afraid it will take a while, as
there are several features to add.


Ilija

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



[Linux Embedded]     [U-Boot V2]     [Linux Kernel]     [Linux MIPS]     [Linux ARM]     [Linux for the Blind]     [Linux Resources]     [Photo]     [Yosemite]     [ISDN Cause Codes]     [ECOS Home]

Add to Google Powered by Linux