Google
  Web www.spinics.net

Re: Help booting a gpg encrypted loop-aes backed root partition

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thanks again to all who responded and especially to Jari who built an
initrd that works.

Using Jari's initrd worked right away without any issues. I suppose
ubuntu 7.04 uses some
weird combinations of compiler/linker options or their package of
dietlibc is somehow incompatible but those are just my speculations and
I am by no means an expert at this. FYI: I also tried to build the
initrd with USEDIETLIBC=0 and that yielded the same result on ubuntu
i.e. it didn't work.

Many thanks again.

Jivko

Jari Ruusu wrote:
> [snip]
> [snip]
>   
>> No filesystems can mount root tried ext2 ext3 minix
>> Kernel panic - not syncing
>> VFS: unable to mount rootfs on unknow-block(1,1)
>>     
>
> Did you see a password prompt before kernel panic?
>
>   
No, there was no password prompt either. It just panicked. Building the
intird with USEPIVOT=0 didn't help.

> I quickly looked at kernel config that you sent me privately. I didn't see
> anything wrong with it.
> [snip]
> 8048383:       65 8b 15 14 00 00 00    mov    %gs:0x14,%edx
>
> which was put there by gcc compiler. Maybe there is some reasonable
> explanation for why that is there, but I didn't immediately see it.
>
> Can you test an initrd that I created for you? I used this config:
>
> BOOTDEV=/dev/hda1
> BOOTTYPE=ext2
> CRYPTROOT=/dev/hda2
> ROOTTYPE=ext3
> CIPHERTYPE=AES128
> INITRDONLY=1
> DESTINATIONPREFIX=/tmp
>
> All other config entries are defaults that are found in unmodified
> loop-AES-v3.2a build-initrd.sh script. You can download it here:
>
> http://koti.tnnet.fi/jari.ruusu/tmp/initrd.gz
> http://koti.tnnet.fi/jari.ruusu/tmp/initrd.gz.sign


-
Linux-crypto:  cryptography in and on the Linux system
Archive:       http://mail.nl.linux.org/linux-crypto/


[Home]     [Kernel]     [Linux Crypto]     [Gnu Crypto]     [Gnu Classpath]     [Netfilter]     [Bugtraq]     [Network Security Reading]

Add to Google