Re: Halt nodes in cluster with cable disconnect

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]




Digimer
in my test when i disconnect the network cable after 6 or 8 seconds, the cluster dies (one node halt and the other reboot), when this happen i reconnect the network cable and start both nodes at the same time, only if i make a --discard-my-data to drbd this show me a connected UpToDate state again.

On Wed, Jan 25, 2012 at 12:37 PM, Digimer <linux@xxxxxxxxxxx> wrote:
On 01/25/2012 12:25 PM, Miguel Angel Guerrero wrote:
> Hi Digimer
>
> i put the new script but i have problems
>
> 1. When i disconnect the network interface one node halt and the other
> reboot,
> 2. After startup both the nodes (at the same time) shows consistent
> state but no connect
>
> The next pastebin shows the logs and drbd state, obliterate-peer.sh
>
> http://pastebin.com/irCBhuAn
>
> For the moment the obliterate-peer.sh script show better result
> than obliterate-peer.sh
>
> thanks for your help again

No prob, but please stay on the mailing list as this might help others
later.

That node couldn't talk to it's peer, and it is not UpToDate, so it
refused to become primary, by design. The network link is still down.

--
Digimer
E-Mail:              digimer@xxxxxxxxxxx
Papers and Projects: https://alteeve.com



--
Atte:
------------------------------------
Miguel Angel Guerrero
Usuario GNU/Linux Registrado #353531
------------------------------------
--
Linux-cluster mailing list
Linux-cluster@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/linux-cluster

[Corosync Cluster Engine]     [Linux RAID]     [Fedora Users]     [Fedora Legacy List]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]

Add to Google Powered by Linux