Re: yum problem with glibc

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On 05/22/2012 05:05 AM, Timothy Murphy wrote:
> Is anyone getting a yum update problem with glibc and glibc-common?
> I'm getting the error message
> -------------------------------
> Error: Protected multilib versions: glibc-2.12-1.47.el6_2.12.x86_64 != 
> glibc-2.12-1.47.el6_2.9.i686
> ** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
> bash-4.1.2-9.el6_2.x86_64 is a duplicate with bash-4.1.2-8.el6.centos.x86_64
> glibc-common-2.12-1.47.el6_2.12.x86_64 is a duplicate with glibc-
> common-2.12-1.47.el6_2.9.x86_64
> glibc-common-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc = ('0', 
> '2.12', '1.47.el6_2.12')
> -------------------------------
> I've tried "rpm --rebuilddb" but that did not seem to help.
>
> Any suggestions or advice gratefully received.
>

You have both the i686 and x86_64 versions of glibc installed.  That
error means that the repo you are trying to update from has a different
version of i686 glibc and x86_64 glibc ... or you are trying to upgrade
one (the x86_64 version) and not the other (the i686 version).

Since multilib installs share some files (all the Documentation, etc.),
that means you must install the same version of each arch if you install
both i686 and x86_64 packages.

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
CentOS mailing list
CentOS@xxxxxxxxxx
http://lists.centos.org/mailman/listinfo/centos

[CentOS]     [CentOS Announce]     [CentOS Docs]     [CentOS Virtualization]     [Linux Media]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Linux USB]     [Project Hail Cloud Computing]

Powered by Linux Add to Google