Re: turning off udev for eth0

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Greetings,

----- Original Message -----
> I have set up a kvm host and configured a standard clone
> prototype for generating new guests. One persistent (pun
> intended) annoyance when cloning is the behaviour of udev
> with respect to the virtual network interface.
> 
> The prototype is configured with just eth0 having a
> dedicated IP addr.  When the prototype is cloned udev
> creates rules for both eth0 and eth1 in the clone.
> Because eth1 does not exist in the cloned guest one has to
> manually edit /etc/udev/rules.d/70-persistent-net.rules to
> get rid of the bogus entries and then restart the clone
> instance to have the changes take effect. All this does is
> return the new guest to the prototype eth0 configuration.
> 
> Is there no way to alter udev's behaviour?  Is udev even
> needed on a server system using virtual hardware?
> Altering the rules file not a big deal in itself but it
> adds needless busywork when setting up a new guest.

That's how it is on physical machines (I image lab computers and have to clean up the udev rules file among other things) and would expect the same behavior from virtual machines.

The limitations of virt-clone are known and are being addressed in virt-sysprep... which hasn't made it to RHEL yet I don't think... but you can find out about it here:

http://rwmj.wordpress.com/2011/10/08/new-tool-virt-sysprep/

TYL,
-- 
Scott Dowdle
704 Church Street
Belgrade, MT 59714
(406)388-0827 [home]
(406)994-3931 [work]
_______________________________________________
CentOS-virt mailing list
CentOS-virt@xxxxxxxxxx
http://lists.centos.org/mailman/listinfo/centos-virt


[CentOS Users]     [Linux Media]     [Asterisk]     [Photo]     [DCCP]     [Netdev]     [Xorg]     [Xfree86]     [Devices]     [Linux USB]

Powered by Linux Add to Google