[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SAP Business Objects XI R2 Infoview Multiple XSS



Class	Input Validation Error
Remote	Yes
Published	10 February 11:00AM
Vulnerable	XI R2

SAP Business Objects is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Version XI R2 is known to be vulnerable. Other versions may also be vulnerable. The vulnerability lies in functionality related to the InfoView system.

The following proof of concept examples are provided:

POST http://www.example.com/businessobjects/enterprise115/InfoView/listing.aspx
searchText=</script><script>alert(1);</script>

https://www.example.com/businessobjects/enterprise115/infoview/help/helpredir.aspx?guide='+alert('XSS 1')+'&lang=en&rpcontext='+alert('XSS 2')+'#

https://www.example.com/businessobjects/enterprise115/infoview/webi/webi_modify.aspx?id='+alert('XSS')+'#

Vendor aware.


[Linux Security]     [Netfilter]     [Linux]     [PHP]     [Photography]     [Yosemite Photos]     [Yosemite News]

Powered by Linux