Google
  Web www.spinics.net

Device not connected but working?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Heya,

Using bluez 4.13, I have a slight problem with a mouse not showing up as
connected.

GetProperties() on the device tells me:
dbus.Dictionary({dbus.String(u'Name'): dbus.String(u'Trust Bluetooth
Mouse', variant_level=1), dbus.String(u'Paired'): dbus.Boolean(False,
variant_level=1), dbus.String(u'Adapter'):
dbus.ObjectPath('/org/bluez/hci0', variant_level=1),
dbus.String(u'Alias'): dbus.String(u'Trust Bluetooth Mouse',
variant_level=1), dbus.String(u'Connected'): dbus.Boolean(False,
variant_level=1), dbus.String(u'UUIDs'):
dbus.Array([dbus.String(u'00001124-0000-1000-8000-00805f9b34fb')],
signature=dbus.Signature('s'), variant_level=1),
dbus.String(u'Address'): dbus.String(u'00:0A:94:C0:AB:9B',

org.bluez.Input.IsConnected() says:
1

$ hidd --show
00:0A:94:C0:AB:9B Trust Bluetooth Mouse [0000:0000] connected

Turning the mouse on and off will sometimes show the connection as being
up, and sometimes not.

Is this normal?

Cheers


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Bluez-devel mailing list
Bluez-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bluez-devel

[Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]    [Yosemite Photos]    [Free Online Dating]     [Linux Kernel]     [Linux SCSI]     [XFree86]

Add to Google Powered by Linux